Bug 48636 - "assembly_load" string not found while loading assemblies in debugger
Summary: "assembly_load" string not found while loading assemblies in debugger
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2016-12-01 20:15 UTC by Andi McClure
Modified: 2016-12-02 20:10 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andi McClure 2016-12-01 20:15:47 UTC
3 times this week in our automated tests, most recently this morning, the test MonoTests.DebuggerTests.AssemblyLoad has failed with an exception about an expected string "assembly_load" not being found. This has so far been seen on Linux 64 and 32 bit.

Linux 32bit
https://jenkins.mono-project.com/job/test-mono-mainline-linux/label=ubuntu-1404-i386/1342/testReport/(root)/DebuggerTests/AssemblyLoad/

                                                  Expected string length 13 but was 8. Strings differ at index 0.
  Expected: "assembly_load"
  But was:  "Finalize"
  -----------^

                                                +++++++++++++++++++
                                                STACK TRACE:
                                                  at MonoTests.DebuggerTests.AssemblyLoad () [0x00073] in /mnt/jenkins/workspace/test-mono-mainline-linux@2/label/ubuntu-1404-i386/mcs/class/Mono.Debugger.Soft/Test/dtest.cs:2336 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <72528ec8eca04fd58e2294df6363c082>:0 

https://jenkins.mono-project.com/job/test-mono-mainline-linux/label=ubuntu-1404-i386/1330/testReport/(root)/DebuggerTests/AssemblyLoad/


                                                MESSAGE:
                                                  String lengths are both 13. Strings differ at index 0.
  Expected: "assembly_load"
  But was:  "ReleaseHandle"
  -----------^

                                                +++++++++++++++++++
                                                STACK TRACE:
                                                  at MonoTests.DebuggerTests.AssemblyLoad () [0x00073] in /mnt/jenkins/workspace/test-mono-mainline-linux@2/label/ubuntu-1404-i386/mcs/class/Mono.Debugger.Soft/Test/dtest.cs:2336 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <60024de0536646db9d658041138fa91c>:0 


Linux 64bit
https://jenkins.mono-project.com/job/test-mono-mainline-linux/label=ubuntu-1404-amd64/1338/testReport/(root)/DebuggerTests/AssemblyLoad/
                                                MESSAGE:
                                                  String lengths are both 13. Strings differ at index 0.
  Expected: "assembly_load"
  But was:  "ReleaseHandle"
  -----------^

                                                +++++++++++++++++++
                                                STACK TRACE:
                                                  at MonoTests.DebuggerTests.AssemblyLoad () [0x00073] in /mnt/jenkins/workspace/test-mono-mainline-linux/label/ubuntu-1404-amd64/mcs/class/Mono.Debugger.Soft/Test/dtest.cs:2336 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <fb37618c55804caea672bfe5a11b0c5b>:0
Comment 1 Zoltan Varga 2016-12-01 20:30:20 UTC
Hopefully fixed by 2d203b2a7718dd8aaf8a3a0fabf816e7dbf331d7.