Bug 48529 - Srollview content is interfering with toolbar
Summary: Srollview content is interfering with toolbar
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 7.1 (C9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2016-12-01 14:21 UTC by John Linton
Modified: 2017-08-25 22:28 UTC (History)
2 users (show)

Tags: XATriaged
Is this bug a regression?: ---
Last known good build:


Attachments
The toolbar's accumulated garbage (573.64 KB, image/png)
2016-12-01 14:21 UTC, John Linton
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description John Linton 2016-12-01 14:21:22 UTC
Created attachment 18738 [details]
The toolbar's accumulated garbage

I have a MasterDetailPage that has a navigation page as its Detail page is a standard content page which contains a scrollview.

As I scroll in this ScrollViewer, any type of UI (the letters in a Label, An Image, etc.) will get caught in the Toolbar that lives in the MasterDetailPage. 

Whenever I click on the toolbar, all of the 'junk' that is accumulated is cleared and it looks normal.

I have not seen this on many android devices, but I have seen it on a Galaxy S6 and some other devices.
Comment 1 Marek Habersack 2016-12-01 16:45:11 UTC
It's hard to say what's causing it without seeing the code. Could you please create a small application that reproduces the issue and attach it to the report? Thanks!
Comment 2 Jimmy [MSFT] 2017-08-25 22:28:11 UTC
Because we did not receive a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!