Bug 48503 - path2 value is null
Summary: path2 value is null
Status: RESOLVED DUPLICATE of bug 48213
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 7.1 (C9)
Hardware: Macintosh Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-11-30 23:50 UTC by teamtim
Modified: 2016-12-20 20:19 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
build log (4.42 MB, text/plain)
2016-11-30 23:55 UTC, teamtim
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 48213

Description teamtim 2016-11-30 23:50:29 UTC
Hello,

This is my config :
Mac OS with Xamarin Cycle 9 last alpha packages
Parallels with Windows 10, VS Update 3 with Xamarin Cycle 9, last SDK packages/build-tools/extras up to date

I have a project with these nuget:
Id                                  Versions 
CommonServiceLocator                {1.3}
ExifLib                             {1.7.0.0}
ExifLib.PCL                         {1.0.1}
HockeySDK.Xamarin                   {4.1.0-alpha3}
MvvmLightLibs                       {5.3.0.0}
SharpZipLib                         {0.86.0}
SQLite.Net.Core-PCL                 {3.1.1}
SQLite.Net-PCL                      {3.1.1}
Xam.Plugin.Connectivity             {2.2.12}
Xam.Plugin.DeviceInfo               {2.0.2}
Xam.Plugins.Forms.DeviceOrientation {1.0.1}
Xamarin.Android.Support.Animated... {23.3.0}
Xamarin.Android.Support.Design      {23.3.0}
Xamarin.Android.Support.v4          {23.3.0}
Xamarin.Android.Support.v7.AppCo... {23.3.0}
Xamarin.Android.Support.v7.CardView {23.3.0}
Xamarin.Android.Support.v7.Media... {23.3.0}
Xamarin.Android.Support.v7.Recyc... {23.3.0}
Xamarin.Android.Support.Vector.D... {23.3.0}
Xamarin.Forms                       {2.3.2.127}
XLabs.Core                          {2.2.0-pre02}
XLabs.Forms                         {2.2.0-pre02}
XLabs.IoC                           {2.2.0-pre02}
XLabs.Platform                      {2.2.0-pre02}
XLabs.Serialization                 {2.2.0-pre02}

I attached the deploy log. As you can see, the path2 value is null.

Regards
Comment 1 teamtim 2016-11-30 23:55:28 UTC
Created attachment 18729 [details]
build log
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2016-12-01 00:05:39 UTC
Thanks for trying the Alpha versions of Xamarin.  This appears to match non-public Bug 48213, which is summarized as follows in the latest Cycle 9 Release Blog post [1]:

"""
Android 7.1.1 (API 25) is not yet supported in this release and can
cause deployment errors such as "Value cannot be null. Parameter name:
path2" if it is installed. A workaround is to uninstall API 25 in the
Android SDK Manager or to disable "Project properties > Application >
Compile using Android version > Use Latest Platform" (in Visual Studio)
or "Project Options > Build > General > Use latest installed platform"
(in Xamarin Studio) if you encounter any deployment failures.
"""

[1] https://releases.xamarin.com/alpha-preview-3-cycle-9/


Indeed the attached build log from Comment 1 shows that API 25 is in use:
> AndroidSdkPlatform=25


If you get a chance, you can check if uninstalling the API 25 SDK or changing the target compile platform does resolve the issue for you too.  Thanks!
Comment 3 teamtim 2016-12-01 08:46:32 UTC
Hello,

I change the compiling version so now it's work.

But now, I have this issue : https://bugzilla.xamarin.com/show_bug.cgi?id=46561

Regards
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2016-12-20 20:19:07 UTC
## Status update, just for thorough bookkeeping

Based on Comment 3, I'll resolve this issue about "Value cannot be null. Parameter name: path2" as a duplicate of non-public Bug 48213.  The latest update on that non-public bug is that it is now resolved in the more recent Alpha versions of Cycle 9.

GOOD - Xamarin.Android 7.1.0.13 (72366f7) (December 05, 2016)
BAD  - Xamarin.Android 7.1.0.9  (46e95bf) (November 28, 2016)

Thanks!

*** This bug has been marked as a duplicate of bug 48213 ***