Bug 4831 - MD crashes after saving - especially if there are build errors
Summary: MD crashes after saving - especially if there are build errors
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.8.8.4
Hardware: Macintosh Mac OS
: High normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-05-02 16:46 UTC by Joseph Hanna
Modified: 2012-05-03 00:24 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Joseph Hanna 2012-05-02 16:46:07 UTC
Description of Problem:
MD crashes out after "Save All" (kbd binding CTRL-SHIFT-S).

I am unable to determine how but this has happened at least 20 times in the last 3 days.  It is more common for it to happen if there are build errors.  Sometimes, if there are build errors in the file, a safe error pops up saying that it cannot save - usually when a "}" or two are missing from the method/prop.  

One way to tell a crash is imminnet is the mouse pointer icon does not change contextually in the editor; ie. it does not change to an "I" when hovering over text - it stays as a pointer.  However, the mouse pointer can still be moved around the screen but it does not respond to clicks or change its icon.


Steps to reproduce the problem:
1. *** Cannot reproduce at will *** but happens frequently when saving and there are build errors.


Actual Results:
MD crashes out and prompts to send error to Apple.


Expected Results:
No crashes!


How often does this happen? 
Minimum of 20 times in the last 3 days.


Additional Information:

I have been importing code files from other projects and going through to fix up build errors, so i can have hundreds of errors at any time. I often use Find/Replace to resolve most of the errors. Not sure if impacts or not so I thought I'd mention it.
Also, when working on a file with lots of errors:  if I need to write a new method to resolve an error, the new method does not appear in the code completion window until the build errors are gone from that file.  Apart from being an inconvenience, I again thought I'd mention it in case there is some link here.

Thanks,
Joe
Comment 1 Mikayla Hutchinson [MSFT] 2012-05-02 16:59:15 UTC
Can you please include the full stack trace from the Apple crash reporting dialog?
Comment 2 Mike Krüger 2012-05-03 00:24:15 UTC
Works for me on 2.9.x. If you can repro it with a 2.9.x alpha reopen that bug.

We could really need the full stack trace btw.