Bug 4807 - GLCube exception on ICS
Summary: GLCube exception on ICS
Status: RESOLVED DUPLICATE of bug 4800
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.1.x
Hardware: PC Mac OS
: --- major
Target Milestone: 4.2
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-05-01 15:08 UTC by PJ
Modified: 2012-05-01 16:06 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 4800

Description PJ 2012-05-01 15:08:40 UTC
Application launch successfully but throwing exception' after changing view.


Steps to reproduce this issue:
1. Open app GLCube.
2. Debug the solution.
3. Change the view


Actual Result:
Cube appears on emulator but after changing view exception displayed 'loaded /system/lib/egl/libGLES_android.so'.

Expected Result:
Application should work properly.

Supplement information:
https://gist.github.com/2567914

Environment:
mono-android-4.1.2.230625174
MonoDevelop-aea1769d05f0ca1fbbf25aa223ee2af419bafbbf
Mac 10.7.3

Device info:
Emulator
version 4.0.3

App info:
GLCube/monodroid-4.1 preview

Additional environment:
This is happening on both debug and release.

Regression status:
REGRESSION


PJ: I reproduced this issue without rotating the device and with GPU enabled - https://gist.github.com/2570551
Comment 1 Jonathan Pryor 2012-05-01 15:12:52 UTC
Does the full logcat output for this run include a message:

W/dalvikvm( ....): ReferenceTable overflow (max=512)

If so, this is a dup of bug 4800.
Comment 2 PJ 2012-05-01 16:06:09 UTC
Yes, full logcat: https://gist.github.com/ff8419b58b44d760ccfd

*** This bug has been marked as a duplicate of bug 4800 ***