Bug 4778 - Problems with app.config file when drilling down to class/method level in Unit Tests pad
Summary: Problems with app.config file when drilling down to class/method level in Uni...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: 2.8.8.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-04-30 17:01 UTC by Randy Syring
Modified: 2012-05-01 00:09 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Randy Syring 2012-04-30 17:01:27 UTC
I have a solution with two projects, like:

- some.project
  * ...snip...
- some.project.tests
  * app.config
  * utils.cs
  * tests.cs

When I use the Unit Tests pad to run tests on some -> Project -> Tests by right-clicking and choose "Run Tests" from within the Unit Tests pad, then all my tests run fine.

However, if I try to drill-down to individual test classes and methods and run just the test class or method, then somehow the app.config no longer gets picked up by ConfigurationManager and I get values from the machine.config file instead.
Comment 1 Randy Syring 2012-04-30 17:12:11 UTC
Clarification: if I drill down to the class level, the config is found for the first two test runs.  However, for the third test run, then the config is no longer found.
Comment 2 Mike Krüger 2012-05-01 00:09:01 UTC
Should work in master.