Bug 47334 - System.ComponentModel.Win32Exception (0x80004005)
Summary: System.ComponentModel.Win32Exception (0x80004005)
Status: RESOLVED ANSWERED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Activation ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-18 05:04 UTC by Kashif Ahmad Khan
Modified: 2016-12-20 16:15 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
SVCLOG file that I have attached from C:\Users\Kashif Ahmad Khan\AppData\Local\Xamarin\Logs\14.0 (9.58 KB, text/plain)
2016-11-18 05:04 UTC, Kashif Ahmad Khan
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Kashif Ahmad Khan 2016-11-18 05:04:00 UTC
Created attachment 18525 [details]
SVCLOG file that I have attached from C:\Users\Kashif Ahmad Khan\AppData\Local\Xamarin\Logs\14.0

Error		Unexpected exception:	App1		
Error		System.ComponentModel.Win32Exception (0x80004005): The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail	App1		
Error		at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)	App1		
Error		at System.Diagnostics.Process.Start()	App1		
Error		at Microsoft.Build.Utilities.ToolTask.ExecuteTool(String pathToTool, String responseFileCommands, String commandLineCommands)	App1		
Error		at Microsoft.CodeAnalysis.BuildTasks.ManagedCompiler.ExecuteTool(String pathToTool, String responseFileCommands, String commandLineCommands)	App1
Comment 1 Kashif Ahmad Khan 2016-11-18 06:45:02 UTC
=========================================
BELOW is from LOG FILE
=========================================
Xamarin Information: 0 : [2016-11-18 11:26:54.5226] Xamarin - 4.2.1.60-cycle8+47830f6
Xamarin.VisualStudio.Activation.AccountManager Information: 0 : [2016-11-18 11:26:54.6812] VS2015 Enterprise
Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-11-18 11:26:54.8938] No license found for iOS
Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-11-18 11:26:55.0254] Running license sync for iOS
Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-11-18 11:26:55.1875] No license found for Android
Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-11-18 11:26:55.3717] Running license sync for Android
Xamarin.VisualStudio.TastyPackage Information: 0 : [2016-11-18 11:26:55.6043] Hooked up SDB tracing adapter
Xamarin.VisualStudio.TastyPackage Information: 0 : [2016-11-18 11:26:55.8005] Initialization finished
Xamarin.VisualStudio.Android.XamarinAndroidPackage Warning: 0 : [2016-11-18 11:26:55.9421] Initializing Xamarin.VisualStudio.Android.XamarinAndroidPackage
Xamarin.VisualStudio.ActivationManager Error: 0 : [2016-11-18 11:27:14.2081] Failed to update Android license: Timeout.

Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-11-18 11:27:14.4052] Read license: Android Community
Xamarin.VisualStudio.ActivationManager Error: 0 : [2016-11-18 11:27:17.1322] Failed to update iOS license: Timeout.

Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-11-18 11:27:17.3153] Read license: iOS Community
Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-11-18 11:27:20.0577] INFO: Changing layoutlib, from 0 to 23
Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-11-18 11:27:20.2284] 
Xamarin.VisualStudio.Android.MonoAndroidFlavoredProject Information: 0 : [2016-11-18 11:27:56.4246] designer model checker: Build
Comment 2 Kashif Ahmad Khan 2016-11-18 06:49:12 UTC
I logged in and logged out many time in Xamarin account in VS2015, but in vain.
Comment 3 Joaquin Jares 2016-12-20 13:51:45 UTC
This is not a debugger bug. Moving to Activation.
Comment 4 Jose Gallardo 2016-12-20 16:15:54 UTC
Hi Kashif,

I see in your logs that there is a timeout issue trying to retrieve the X.iOS and X.Android licenses, but given that you're using VS 2015 Enterprise, you should be able to actually use Xamarin without being logged in at all.
Please just log out and try using the product.

If the problem is not fixed, can you please confirm if you have internet access from that box? Please feel free to re-open the issue if that's the case.

Thanks!