Bug 47290 - Native Exception, threadpool-ms-io.c:344, condition `fd >= 0' not met, libmonosgen-2.0.so
Summary: Native Exception, threadpool-ms-io.c:344, condition `fd >= 0' not met, libmon...
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 7.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2016-11-17 22:37 UTC by Daniel Vaughan
Modified: 2017-08-23 20:35 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Daniel Vaughan 2016-11-17 22:37:08 UTC
I have an app on Google Play, built using Xamarin.Android 7.0, which is crashing the app at launch on some devices using arm64. I have since determined that unchecking arm64-v8a prevents the issue.

The exception information is as follows:

Build fingerprint: 'Xiaomi/land/land:6.0.1/MMB29M/V7.5.9.0.MALMIDE:user/release-keys'
Revision: '0'
ABI: 'arm64'
pid: 9657, tid: 9761, name: Thread-2227 >>> com.outcoder.browser <<<
signal 6 (SIGABRT), code -6 (SI_TKILL), fault addr --------
Abort message: '* Assertion at /Users/builder/data/lanes/3819/96c7ba6c/source/mono/mono/metadata/threadpool-ms-io.c:344, condition `fd >= 0' not met
'
x0 0000000000000000 x1 0000000000002621 x2 0000000000000006 x3 0000000000000000
x4 0000000000000000 x5 0000000000000001 x6 0000000000000000 x7 0000000000000000
x8 0000000000000083 x9 0000007f75365000 x10 0000007f75366012 x11 0000000000000000
x12 0000007f75365000 x13 0000007f75350090 x14 0000000000000001 x15 0000007f75354e39
x16 0000007f784826a8 x17 0000007f78444b6c x18 0000000000000000 x19 0000007f2fa65510
x20 0000007f2fa65450 x21 0000000000000000 x22 0000000000000006 x23 0000007f617ac804
x24 0000005575215114 x25 0000000000000000 x26 ffffffffffffffff x27 0000007fe90a7df0
x28 0000000000001000 x29 0000007f2fa64fe0 x30 0000007f78442308
sp 0000007f2fa64fe0 pc 0000007f78444b74 pstate 0000000020000000

backtrace:
#00 pc 000000000006ab74 /system/lib64/libc.so (tgkill+8)
#01 pc 0000000000068304 /system/lib64/libc.so (pthread_kill+68)
#02 pc 00000000000212f8 /system/lib64/libc.so (raise+28)
#03 pc 000000000001ba98 /system/lib64/libc.so (abort+60)
#04 pc 000000000021e470 /data/app/com.outcoder.browser-1/lib/arm64/libmonosgen-2.0.so
Comment 1 John Miller [MSFT] 2017-07-06 14:15:04 UTC
Thank you for taking the time to submit the bug. We are unable to reproduce this issue. Please attach a reproduction to the bug by starting with a clean Xamarin.Android project and adding just the code necessary to demonstrate the issue. Also, please some more details about which specific devices you noticed this issue on. Thank you!
Comment 2 Cody Beyer (MSFT) 2017-08-23 20:35:09 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!