Bug 47144 - Going from XVS C9 4.3.0.x build to C8 4.2.1.x build requires forgetting remembered Mac Agent to connect via XMA
Summary: Going from XVS C9 4.3.0.x build to C8 4.2.1.x build requires forgetting remem...
Status: VERIFIED ANSWERED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- major
Target Milestone: 4.3.0 (C9)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-16 21:44 UTC by Ben Beckley
Modified: 2016-11-29 20:07 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
logs (5.81 KB, application/x-zip-compressed)
2016-11-16 21:44 UTC, Ben Beckley
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED ANSWERED

Description Ben Beckley 2016-11-16 21:44:39 UTC
Created attachment 18491 [details]
logs

If you are using a C9 XVS build and then you want to go back to C8, and try to connect to a remembered build agent - it fails with a message in the Xamarin output along the lines of:
>Starting connection to Mac 10.160.88.103...
>Couldn't connect to 10.160.88.103. Please try again.

The solution is simple, yet not obvious or apparent. Right clicking on the desired Mac in the server selector and choosing "Forget this Mac". 

Reproduction Steps:
1) Install C9 XVS
2) Connect to a Mac Agent via XMA
3) Downgrade to C8 XVS
4) Attempt to connect to same Mac Agent
5) Observe Xamarin output stating "Couldn't connect to Mac..."
Expected behavior: It should connect, or at the very least give a more actionable message.
Comment 1 Jose Gallardo 2016-11-22 17:34:15 UTC
This is correct, and unfortunately we cannot change it.
We should document it as a Known Issue though.

I've added a Known Issue as part of the Release Notes to properly communicate it.

Thanks for the catch.