Bug 4689 - Assembly Browser does not show protected members.
Summary: Assembly Browser does not show protected members.
Status: VERIFIED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Assembly browser ()
Version: 2.9.x
Hardware: PC Mac OS
: High major
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-04-27 08:24 UTC by Eric Beisecker
Modified: 2012-04-27 11:31 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED NOT_REPRODUCIBLE

Description Eric Beisecker 2012-04-27 08:24:31 UTC
In the 2.9.x series of MonoDevelop certain protected Members are hidden in the Assembly Browser while in the 2.8.8 series of Monodevelop the assembly browser would list them.

Assembly Browser for 2.9.6: http://www.screencast.com/t/rZVSLawF4HgJ

Assembly Browser for 2.8.8: http://www.screencast.com/t/irnlhginw7qi

Setting to high priority as this is a regression.
Comment 1 Mike Krüger 2012-04-27 10:48:54 UTC
Works for me - there is a combo box at the top where you can switch between public and all members.
Comment 2 Eric Beisecker 2012-04-27 11:31:21 UTC
Intersting, for me the 'all memebers' option only shows the Members in the actual Browser and not the Type Hierarchy list for this specific project only. I created a test project and it seems to work as intended.

There is another bug where the 'Go To Defination' doesn't seem to work on Members that are protected, I'll create another bug for that one and close this one.