Bug 46810 - android Native Library import not working...
Summary: android Native Library import not working...
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: --- blocker
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2016-11-11 16:48 UTC by nicola
Modified: 2016-11-14 09:15 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
solution that reproduce the issue (22.62 KB, application/x-zip-compressed)
2016-11-11 16:50 UTC, nicola
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description nicola 2016-11-11 16:48:25 UTC
# Steps to reproduce
I need to use a .arr library from a xamarin android project. It looks like very easy but, I have created a "binding library" project, under jar folder I have added the .arr file. Build ok, but if I go to "class view", I can't see any class exposed by .arr library... what I'm missing?

in attach the minimal solution that reproduce the issue.

# Expected behavior
after build, If I go to class view I should see the classes exposed by arr library

# Actual behavior
no classes explosed

# Supplemental info (logs, images, videos)


# Test environment (full version information)
Comment 1 nicola 2016-11-11 16:50:46 UTC
Created attachment 18431 [details]
solution that reproduce the issue
Comment 2 nicola 2016-11-14 09:15:27 UTC
found a solution. not a bug!