Bug 4681 - Error occurring when debugging System.IO.MonoIO loaded more than once
Summary: Error occurring when debugging System.IO.MonoIO loaded more than once
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- trivial
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-04-26 18:59 UTC by lindsey.driscoll
Modified: 2012-05-02 20:30 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Lame console project with error (3.68 KB, application/zip)
2012-04-27 17:02 UTC, lindsey.driscoll
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description lindsey.driscoll 2012-04-26 18:59:46 UTC
Screencast: http://screencast.com/t/iBUINvVAAWh5

Steps to reproduce:

Debug a console application with md logging enabled

export MONODEVELOP_LOGGING_PAD_LEVEL=UpToDebug


Outcome:

In the message log pad notice a

"Error - 6:45:47 PM - Type 'System.IO.MonoIO' loaded more than once" message


Environment:

MacOSX: Lion
MD: 2.9.6 (revision-da6068e783f7620fdb6879fc89320a185d9e2b9b)
Mono: 2.10.9


Note:

Saw this in earlier builds of master as well -> 2.9.5
Comment 1 Jeffrey Stedfast 2012-04-27 16:41:24 UTC
can you attach the console app project? I can't seem to reproduce
Comment 2 lindsey.driscoll 2012-04-27 17:01:19 UTC
Jeff:

I narrowed it down to when this error is "thrown":

To reproduce:

Create some System.Diagnostics.Process (I just did a which command)
and call process.Start()

Then you should see the error message in the message log.


I'll attach the project as well
Comment 3 lindsey.driscoll 2012-04-27 17:02:41 UTC
Created attachment 1770 [details]
Lame console project with error
Comment 4 Zoltan Varga 2012-05-02 20:30:40 UTC
The error is now disabled, it can happen during normal operation.