Bug 46761 - OnResume called multiple times iOS 10
Summary: OnResume called multiple times iOS 10
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 10.2 (iOS 10.1)
Hardware: PC Windows
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-10 19:33 UTC by Samiya A
Modified: 2016-12-19 18:22 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Samiya A 2016-11-10 19:33:08 UTC
OnResume is being called multiple times when the app is resumed from sleeping state. Also, when the app loads for the first time it's being called but the docs say it's only called when it's resumed from sleeping state. In my project this is 100% reproducible.
Comment 1 Alex Soto [MSFT] 2016-11-15 06:55:50 UTC
Hello, 

I think you are using Xamarin.Forms right? Please include a test case (to reproduce) and all version informations, including the X.F version you are using.

The easiest way to get exact version information is to use the 
"Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" 
button and copy/paste the version informations (you can use the 
"Copy Information" button).
Comment 2 Timothy Risi 2016-12-19 18:22:54 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!