Bug 46574 - Visual Studio 2015 going to crash every time I try to add services references in PCL project
Summary: Visual Studio 2015 going to crash every time I try to add services references...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.3
Assignee: vga
URL:
Depends on:
Blocks:
 
Reported: 2016-11-08 14:43 UTC by Fabio
Modified: 2017-07-19 14:34 UTC (History)
6 users (show)

Tags: visualstudio, service reference
Is this bug a regression?: ---
Last known good build:


Attachments
Project config (42.10 KB, image/png)
2016-11-08 14:43 UTC, Fabio
Details
add service reference (77.16 KB, image/png)
2016-11-08 14:44 UTC, Fabio
Details
generating proxy class before crash (3.29 KB, image/png)
2016-11-08 14:44 UTC, Fabio
Details
crash (33.71 KB, image/png)
2016-11-08 14:45 UTC, Fabio
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Fabio 2016-11-08 14:43:43 UTC
Created attachment 18375 [details]
Project config

I use Visual Studio 2015 on a Windows 10 Pro x64 ( Build 14393.351) and, when I try to add an ASMX service reference in a PLC project ( notice that I removed Win Phone 8.1 compatibility from PCL project and I don't have a Win Phone 8.1 project in solution), Visual studio going to crash during generation of service references client code and, after restart it, the service references aren't present in the project and in the Service Reference folder the file Reference.cs is missing. I've tried to add the same service reference in a simple console application and the the process finished correctly.

For example, I've created a test solution with the only PCL project ( no Android/iOS/Win project in this solution) and I've tried to add ( after removing support for WinPhone 8 compatibility in PCL project) a service reference to this ws: http://www.w3schools.com/xml/tempconvert.asmx but VS going to crash every time i make this. I've attached some screenshot about this.

Notice that I also tried on another pc with similar configuration (Visual Studio 2015 Pro on Win 10 Enterprise x64) and I have encountred the same issue. 
I'm very afraid about this situation, anyone can help me or know a workaround for this problem?

I make another test with a clean installation of Win 10 Pro x86 and Visual Studio 2015 Community Update 3 and I have the same issue.

Thank's in advance

This is my VS configuration:

Microsoft Visual Studio Community 2015 Version 14.0.25431.01 Update 3
Microsoft .NET Framework Version 4.6.01586
Xamarin 4.2.0.719 (15694b9)
Xamarin.Android 7.0.1.6 (5a02b03)
Xamarin.iOS 10.2.0.4 (b638977)
Comment 1 Fabio 2016-11-08 14:44:18 UTC
Created attachment 18376 [details]
add service reference
Comment 2 Fabio 2016-11-08 14:44:54 UTC
Created attachment 18377 [details]
generating proxy class before crash
Comment 3 Fabio 2016-11-08 14:45:07 UTC
Created attachment 18378 [details]
crash
Comment 4 vga 2016-12-22 18:14:41 UTC
Hi Fabio,

Sorry for the delay in getting back. If I'm following you, it looks like Xamarin isn't involved in this crash, as you have tried to add a reference to a solution including just a PCL project with no Xamarin projects, and you still see the crash.

Is this right?
Comment 5 Juan Marcelo Tondato 2017-06-21 20:34:26 UTC
Marking tentatively as Resolved/Fixed to get verification with latest bits. If you're still seeing this issue please feel free to reopen and add the environment info. Thanks!
Comment 6 Alok Kulkarni 2017-07-19 14:34:00 UTC
I am using VS2015 Version 14.0.25431.01 Update 3, but not seen any option to add Service Reference to the PCL Project.

Steps Performed :
1. Created PCL Project in VS2015.
2. Removed UWP from the solution.
3. Build solution, Right click on PCL Project to add Service Reference.

Performed some additional steps like :

1. Manualy edit the .csproj file.
2. Add <TargetFrameworkProfile>Profile78</TargetFrameworkProfile>.

But not seen any Service Reference Option.

Am I going right to verify the bug, kindly suggest.

Build Info : https://gist.github.com/alok-kulkarni/b9a11f678ea7cbe7b8e2d6d95efcffc4