Bug 46530 - DisplayActionSheet on Windows aligns title and button without left and bottom padding
Summary: DisplayActionSheet on Windows aligns title and button without left and bottom...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jimmy [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-11-06 18:47 UTC by Jos Huybrighs
Modified: 2017-12-05 16:44 UTC (History)
5 users (show)

Tags: uwp, actionsheet, fr
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot (19.55 KB, image/png)
2016-11-06 18:47 UTC, Jos Huybrighs
Details
repro project (116.57 KB, application/x-zip-compressed)
2017-03-01 19:54 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jos Huybrighs 2016-11-06 18:47:42 UTC
Created attachment 18352 [details]
Screenshot

The Title and Button in a DisplayActionSheet is poorly aligned when rendered on Windows (UWP, Mobile 10, Phone, ..).
Title should have some left padding (aligned with the 'action' buttons) and have a standard XAML Title style (font a bit bigger, ..).
Similar issue with the button which appears completely aligned with the popup bottom border line. Also here is some padding needed.
What is also missing is a gray overlay on the page where the popup appears. That is standard in Windows UWP (desktop and mobile 10).
For android everything is OK.
Comment 1 Jimmy [MSFT] 2017-03-01 19:53:43 UTC
Thank you for filing this report! I am able to reproduce the issue you described using the repro project I'm attaching. I am confirming this report and the engineering team will look more into this.

### Repro status
Forms 2.3.3.180     BAD
Forms 2.3.4-pre2    BAD
Forms 2.3.5-nightly BAD
Comment 2 Jimmy [MSFT] 2017-03-01 19:54:10 UTC
Created attachment 20068 [details]
repro project
Comment 3 Samantha Houts [MSFT] 2017-04-24 18:12:08 UTC
https://github.com/xamarin/Xamarin.Forms/pull/881
Comment 4 Rui Marinho 2017-12-05 16:44:34 UTC
Should be fixed on 2.6.0-pre1