Bug 46469 - Mono 4.6.2 / mdoc: Failed to resolve assembly: 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
Summary: Mono 4.6.2 / mdoc: Failed to resolve assembly: 'System.Runtime, Version=4.0.0...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Tools
Classification: Mono
Component: Doctools ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-04 13:41 UTC by RobertN
Modified: 2017-05-31 15:39 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description RobertN 2016-11-04 13:41:42 UTC
Cmd line failure of mdoc to resolve System.Runtime, Version=4.0.0.0

   monodocer -assembly:RealmJson.Extensions.dll -path:en 
   mdoc: Failed to resolve assembly: 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
   See `mdoc help' for more information or use --debug to diagnose.

Installed mono:
   Mono JIT compiler version 4.6.2 (mono-4.6.0-branch/db69866 Mon Oct 31 16:58:55 EDT 2016)
Comment 1 Alexander Köplinger [MSFT] 2017-05-31 15:39:57 UTC
This seems to work now in Mono 5.0.1. I tried with an assembly that references System.Runtime v4.0.