Bug 4628 - Projects in a Workspace double when renamed
Summary: Projects in a Workspace double when renamed
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 2.8.8.4
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-04-24 16:11 UTC by Ian
Modified: 2015-12-03 18:01 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Doubling (59.25 KB, image/jpeg)
2012-04-24 16:11 UTC, Ian
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Ian 2012-04-24 16:11:18 UTC
Created attachment 1740 [details]
Doubling

Add a few solutions to a Workspace.
Press CTRL+R to rename the workspace.

The result is that all the projects double in the view. You must reboot the IDE to clear it.

See attached picture.

MonoDevelop 2.8.8.4
Runtime:
	Mono 2.10.9 (tarball Tue Apr 17 18:59:12 EDT 2012)
	GTK 2.24.10
	GTK# (2.12.0.0)
Apple Developer Tools:
	 Xcode 4.3.1 (1176)
	 Build 4E1019
Monotouch: 5.2.11
Comment 1 Rajneesh Kumar 2015-12-03 17:55:36 UTC
I have checked this issue but it seems that this is no longer reproducible. To reproduce this issue I have followed the steps provided in the bug description, but not able to do so.

Screencast: http://www.screencast.com/t/TSKebBva

This issue seems fixed to me, hence I am closing this issue.

Thanks..!

Environemnt Info:
=== Xamarin Studio ===

Version 5.10.1 (build 4)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 4.2.1 (explicit/6dd2d0d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010102

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Not Installed

=== Xamarin Android Player ===

Version: 0.6.1
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.1 (9079)
Build 7B91b

=== Xamarin.iOS ===

Version: 9.2.1.55 (Business Edition)
Hash: edf4e56
Branch: master
Build date: 2015-12-01 18:52:47-0500

=== Xamarin.Mac ===

Version: 2.5.0.2277 (Business Edition)

=== Build Information ===

Release ID: 510010004
Git revision: d107b5c0aa98c5f4cdf025bf096812fb0b937987
Build date: 2015-12-01 18:01:49-05
Xamarin addins: 83e91c86bddb2ffbe2451c8c21936dcf74982459
Build lane: monodevelop-lion-cycle6-baseline

=== Operating System ===

Mac OS X 10.11.0
Darwin Admin-Macs-Mac-mini.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64