Bug 4624 - [AutoComplete] Attribute autocomplete inserts entire attribute class name.
Summary: [AutoComplete] Attribute autocomplete inserts entire attribute class name.
Status: RESOLVED DUPLICATE of bug 4666
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 2.9.x
Hardware: PC Mac OS
: Normal minor
Target Milestone: ---
Assignee: Mike Krüger
URL:
: 4604 ()
Depends on:
Blocks:
 
Reported: 2012-04-24 15:12 UTC by Eric Beisecker
Modified: 2012-04-26 08:52 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 4666

Description Eric Beisecker 2012-04-24 15:12:44 UTC
Current Behavior: While typing an attribute name, autocomplete will insert the whole Class name of the Attribute.  (ex. if the class name is TestAttribAttribute it will insert TestAttribAttribute instead of just TestAttrib) 

Expected Behavior: Based on the behavior in Visual Studio Intellisense only inserts the Shortened name of the Attribue. (TestAttrib)


MonoDevelop 2.9.5
Runtime:
	Mono 2.10.9 (tarball Tue Apr 17 18:59:12 EDT 2012)
	GTK 2.24.10
	GTK# (2.12.0.0)
Comment 1 Mike Krüger 2012-04-25 01:57:16 UTC
Works for me - do you have a use case ?
Comment 2 Eric Beisecker 2012-04-25 11:36:38 UTC
This seems to only happen on Enum members.

Ex. 
enum TestEnum
{
   [EnumAttribute]
   EnumMember
}

Screencast: http://screencast.com/t/uZXWQjH2
Comment 3 Mike Krüger 2012-04-25 12:20:57 UTC
... seems that all unchecked cases are always buggy :). I did several attribute checks - but not for enums :/
Comment 4 Mike Krüger 2012-04-26 08:44:43 UTC
*** Bug 4604 has been marked as a duplicate of this bug. ***
Comment 5 Mike Krüger 2012-04-26 08:52:36 UTC

*** This bug has been marked as a duplicate of bug 4666 ***