Bug 46163 - PanGestureRecognizer Completed doesn't fire in UWP when pointer off the page
Summary: PanGestureRecognizer Completed doesn't fire in UWP when pointer off the page
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-28 19:49 UTC by Chris Turner
Modified: 2017-09-30 11:36 UTC (History)
4 users (show)

Tags: uwp, pangesturerecognizer, ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 46163 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Chris Turner 2016-10-28 19:49:44 UTC
When you use a PanGestureRecognizer in a UWP app, if you move the pointer off the app's screen area the GestureStatus.Completed doesn't get triggered in the PanUpdated event.

This can happen when running on a device if you perform a long swipe but is easier to reproduce by running on the desktop and panning with the mouse.

Use the attached demo app to reproduce.
Comment 1 Chris Turner 2016-10-28 21:26:00 UTC
In case someone else has experienced the same problem I have created a work-around by handling the PointerExited event in the native UWP control and feeding this event back to my xamarin forms control.
Comment 2 E.Z. Hart [MSFT] 2016-10-31 15:07:41 UTC
(In reply to Chris Turner from comment #0)
> Use the attached demo app to reproduce.

Chris,

You mentioned an attachment but I don't see one in the Bugzilla case. Could you try uploading it again? 

Thanks.
Comment 3 Chris Turner 2016-10-31 18:08:36 UTC
Hi,

I think the attachment may have been rejected because it was too large.  You can download it here: 
https://1drv.ms/u/s!AmgkjEjadrvTkIA3EunwN-EoeuMytA
Comment 4 E.Z. Hart [MSFT] 2016-10-31 18:42:05 UTC
Confirmed. Note that this is a desktop issue; it works fine on the phone. Also happens in Windows 8.1 on the desktop.