Bug 45996 - Adding Items to carouselView after initial load does not work on uwp
Summary: Adding Items to carouselView after initial load does not work on uwp
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jimmy [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-10-27 10:24 UTC by FieldstrikeMobile
Modified: 2017-05-10 14:02 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
sample project (271.26 KB, application/x-zip-compressed)
2017-03-24 21:39 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description FieldstrikeMobile 2016-10-27 10:24:13 UTC
Create a uwp application with a carouselview.

After loading have a button that adds items to the carouselview.

items are not added to the carousel.

no collection changed events fire

eventually you get a crash
Comment 1 Jimmy [MSFT] 2017-03-24 21:39:57 UTC
Created attachment 20837 [details]
sample project

I couldn't reproduce this issue with the sample project I'm attaching. Can you confirm that you are still seeing this issue with the latest version of Forms and Forms.CarouselView? 

If yes, can you attach a repro project so we can continue looking into this? Please note that we may close this issue after 30 days of no response. Thanks!


### Version Tested
Forms 2.3.3.193
Forms.CarouselView 2.3.0-pre2
Comment 2 FieldstrikeMobile 2017-05-10 14:02:59 UTC
Fixed in new Carousel that is in the process of being merged:

https://github.com/xamarin/Xamarin.Forms/pull/853