Bug 45961 - xbuild will not build if project file path contains %20
Summary: xbuild will not build if project file path contains %20
Status: CONFIRMED
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: 4.8.0 (C9)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-26 21:31 UTC by jamie
Modified: 2016-10-27 20:22 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 45961 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description jamie 2016-10-26 21:31:42 UTC
I noticed that if you try to build a project with %20 in the file path then it will not build at all, the IDE gives unknown error and the terminal shows the real reason:

/Users/x/Documents/Work/Wire%20Mobile/src/Wire.sln: error : Could not find a part of the path "/Users/x/Documents/Work/Wire Mobile/src/Wire.sln".

Visual Studio Team Services (git) uses %20 in place of spaces in file paths so this is necessary.
Comment 1 jamie 2016-10-26 21:32:38 UTC
Note - using xbuild
Comment 2 Jeffrey Stedfast 2016-10-27 20:22:15 UTC
Confirmed. This is a problem with standard .NET apps as well.