Bug 45838 - Content Page OnAppearing does not fire when app resumes from background.
Summary: Content Page OnAppearing does not fire when app resumes from background.
Status: RESOLVED DUPLICATE of bug 44855
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-24 14:49 UTC by Richard Amiss
Modified: 2017-03-20 01:00 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 44855

Description Richard Amiss 2016-10-24 14:49:31 UTC
# Steps to reproduce
1) Open New PCL (Xamarin.Forms) Project.
2) Add a Content Page (MainPage)
3) Put a Debug.WriteLine in App.cs OnResume and another in the Content Page OnAppearing.
4) Debug the App.
5) While debugging press the device's Home Button
6) Click on the App icon (to re-open the App.

# Expected behavior
When the App re-appears both the App.cs OnResume AND the Content Page OnAppearing events should fire.

# Actual behavior
Only the App.cs OnResume event fires. Only that Debug line displays. The Content Page OnAppearing event does NOT fire, even thought that page just "appeared".  I have to use Messaging Center for now as a workaround.

# Supplemental info (logs, images, videos)
n/a

# Test environment (full version information)
Using Xamarin Forms Beta Cycle 8 - Released 10/16/2016
Comment 1 adrianknight89 2016-10-24 15:11:13 UTC
Is this for Android? It might be a duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=44855
Comment 2 Richard Amiss 2016-10-24 15:16:17 UTC
This is for iOS. You are correct in that it seems to be a duplicate (other than the specific OS)
Comment 3 adrianknight89 2016-10-24 15:23:08 UTC
I don't think iOS calls appearing events on app sleep/resume. Only Android does, and even then there was a property introduced recently to turn off this behavior on Android.

See https://github.com/xamarin/Xamarin.Forms/pull/450

You can use MessagingCenter on sleep/resume if you want pages to respond to such changes.
Comment 4 Paul DiPietro [MSFT] 2017-03-20 01:00:38 UTC

*** This bug has been marked as a duplicate of bug 44855 ***