Bug 45831 - Characters added to wrong EntryCell if keyboard once 'Text' and once 'Numeric' on Android 7
Summary: Characters added to wrong EntryCell if keyboard once 'Text' and once 'Numeric...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.3.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-24 12:45 UTC by martin.vogt
Modified: 2018-03-21 16:04 UTC (History)
5 users (show)

Tags: ac XamExtTriage
Is this bug a regression?: ---
Last known good build:


Attachments
Project to reproduce (93.09 KB, application/zip)
2016-10-24 12:45 UTC, martin.vogt
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description martin.vogt 2016-10-24 12:45:42 UTC
Created attachment 18188 [details]
Project to reproduce

I have a table view with two entry cells. One entry cell has keyboard 'Text', the other one keyboard 'Numeric'. I tab on the first entry cell and enter text. Then I tab on the second entry cell (numerical). The cell is highlighted and the cursor is at the correct position. But the keyboard is wrong (text) and if I enter text, the characters are added to the wrong first cell.
This happens on my Nexus 9 since I upgraded to Android 7.

I see the following lines in the output window of Visual Studio 2015:

10-24 14:08:44.978 W/IInputConnectionWrapper( 6779): finishComposingText on inactive InputConnection
10-24 14:08:44.978 W/IInputConnectionWrapper( 6779): beginBatchEdit on inactive InputConnection
10-24 14:08:44.978 W/IInputConnectionWrapper( 6779): getSelectedText on inactive InputConnection
10-24 14:08:44.979 W/IInputConnectionWrapper( 6779): endBatchEdit on inactive InputConnection
10-24 14:08:44.979 W/IInputConnectionWrapper( 6779): getTextBeforeCursor on inactive InputConnection
10-24 14:08:44.979 W/IInputConnectionWrapper( 6779): getTextAfterCursor on inactive InputConnection
10-24 14:08:44.983 W/IInputConnectionWrapper( 6779): finishComposingText on inactive InputConnection
10-24 14:08:46.239 W/IInputConnectionWrapper( 6779): finishComposingText on inactive InputConnection
10-24 14:08:46.239 W/IInputConnectionWrapper( 6779): finishComposingText on inactive InputConnection

Xamarin Forms: 2.3.2.127
Xamarin Android: 7.0.1.3
Xamarin: 4.2.0.703
Comment 1 Paul DiPietro [MSFT] 2016-10-31 20:04:56 UTC
It appears possible that this is being caused by https://code.google.com/p/android/issues/detail?id=223859.
Comment 2 Rui Marinho 2017-06-29 15:13:48 UTC
This was fixed on 2.3.4 stable
Comment 3 elielson.goncalves.anjos 2018-03-21 16:04:57 UTC
Still getting the exactly same bug on Xamarin Forms 2.5.0.280000.