Bug 45817 - All Visual Studio Xamarin updates fail with "Xamarin Setup Wizard ended prematurely"
Summary: All Visual Studio Xamarin updates fail with "Xamarin Setup Wizard ended prema...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: 4.1.1 (C7SR0)
Hardware: PC Windows
: High normal
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-23 18:19 UTC by gozer61
Modified: 2017-07-11 15:28 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log file output from install attempt (45.03 KB, application/octet-stream)
2016-10-24 18:24 UTC, gozer61
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description gozer61 2016-10-23 18:19:38 UTC
I can install Xamarin using Visual Studio 2015's "Cross Platform mobile Development" setup option, which gives me Xamarin version 4.1.1.3.  This version is operational and I can build and debug Xamarin projects.

Attempting to update this install using Visual Studio 2015's "Tools/Options/Xamarin/Other/Check Now" link finds version 4.2.0.703, which downloads and runs, but ends with the stated problem without performing the install.

I manually downloaded Xamarin.VisualStudio_4.2.0.698.msi, .695, .680, and even 4.1.2.18.  All fail with the same problem and do not perform the update.

I cannot find any log files that might describe why these updates fail.

I have tried uninstalling and reinstalling Xamarin using Visual Studio's setup but this does not change the result.

Any suggestions as to
  1. Where I can find a setup or install log file that might have additional information on the setup failure, and
  2. What things I could look for on my machine to make these updates work?

I am running Windows 7 x64 with all the latest updates.

Here's my Visual Studio info:

Microsoft Visual Studio Professional 2015
Version 14.0.25421.03 Update 3
Microsoft .NET Framework
Version 4.6.01055

Installed Version: Professional

LightSwitch for Visual Studio 2015   00322-50051-38891-AA424
Microsoft LightSwitch for Visual Studio 2015

Visual Basic 2015   00322-50051-38891-AA424
Microsoft Visual Basic 2015

Visual C# 2015   00322-50051-38891-AA424
Microsoft Visual C# 2015

Visual C++ 2015   00322-50051-38891-AA424
Microsoft Visual C++ 2015

Application Insights Tools for Visual Studio Package   7.10.01020.1
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1 (Beta8)   14.1.11107.0
ASP.NET and Web Tools 2015.1 (Beta8)

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Clear MEF Component Cache   1.3.1
Clears the Visual Studio MEF component cache to fix issues with cache corruption.

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

KofePackagePackage Extension   1.0
KofePackagePackage Visual Studio Extension Detailed Info

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

NuGet Package Manager   3.4.4
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

Office Developer Tools for Visual Studio 2015 ENU   14.0.23025
Microsoft Office Developer Tools for Visual Studio 2015 ENU

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   14.0.60519.0
Microsoft SQL Server Data Tools

TypeScript   1.8.34.0
TypeScript tools for Visual Studio

Visual C++ for Cross Platform Mobile Development (Android)   14.0.25401.00
Visual C++ for Cross Platform Mobile Development (Android)

Visual Studio Tools for Universal Windows Apps   14.0.25527.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin   4.1.1.3 (34a92cd)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   6.1.1.1 (7db2aac)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   9.8.1.4 (3cf8aae)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 1 Ben Beckley 2016-10-24 17:57:30 UTC
Hello,

Being that the msi is flat out failing, could you please attach diagnostic msi installation logs?

You can get it by running the following command from the cmd prompt:
msiexec /i <path_to_msi> /L*V C:\Logs\xamarin_msi.xml

Thank you.
Comment 2 gozer61 2016-10-24 18:24:26 UTC
Created attachment 18203 [details]
Log file output from install attempt

here's a log file i generated trying to run the latest .msi file.
Comment 4 vga 2016-12-22 18:21:05 UTC
Sorry for the delay in getting to this. I'm taking a look at it now and will let you know what I find.
Comment 5 Pierce Boggan [MSFT] 2017-07-11 15:28:19 UTC
Thanks so much for taking the time to submit this report! I attempted to reproduce this issue based on the bug description with the latest Visual Studio 2017 Preview version 15.3, and I was unable to hit the problem. If this issue is still occurring for you, please reopen this report and attach a reproduction, ideally starting with a new template project and then adding just the code necessary to demonstrate the issue.