Bug 45814 - Could not install package 'Xamarin.Forms 2.2.0.45'. You are trying to install this package into a project that targets 'Unsupported,Version=v0.0'" when adding a new XAML page to a Forms Shared Project.
Summary: Could not install package 'Xamarin.Forms 2.2.0.45'. You are trying to install...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-23 04:27 UTC by Prashant
Modified: 2017-02-01 19:17 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Error Screen Shot (177.39 KB, image/png)
2016-10-23 04:27 UTC, Prashant
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Prashant 2016-10-23 04:27:01 UTC
Created attachment 18181 [details]
Error Screen Shot

I am error with new Xamarin updates in VS-2015.
## Description
When adding a new XAML page to a new Forms Shared project, an error dialog is displayed with the following text:
>---------------------------
>Microsoft Visual Studio
>---------------------------
>Package Installation Error
>Could not add all required packages to the project. The following packages failed to install from 'C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO 14.0\COMMON7\IDE\EXTENSIONS\IAEIO05K.AB5\Packages':Xamarin.Forms.2.2.0.45 : Could not install package 'Xamarin.Forms 2.2.0.45'. You are trying to install this package into a project that targets 'Unsupported,Version=v0.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.
>---------------------------
Though, I am able to build and deploy the project on device but Xaml intelligence is not working.

Updating Xamarin.Forms library from nuget to latest stable 2.3.2.127 didn't work.
Comment 1 Samantha Houts [MSFT] 2017-02-01 19:17:21 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. 

If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction. 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d  

Warm regards, 
Xamarin Forms Team