Bug 4579 - Unit Test Projects do not invoke the [Setup] method
Summary: Unit Test Projects do not invoke the [Setup] method
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 5.3.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-04-21 23:04 UTC by Miguel de Icaza [MSFT]
Modified: 2012-04-21 23:16 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Miguel de Icaza [MSFT] 2012-04-21 23:04:25 UTC
Unit Test projects in MonoTouch do not invoke the methods to setup the test suite.

The following sample test added to a test suite fails:


using System;
using NUnit.Framework;

namespace test1
{
	[TestFixture]
    public class t1
	{
		bool run;
		
		[SetUp]
		void Demo ()
		{
			run = true;
		}
		
		[Test]
		public void Pass ()
		{
			Assert.True (run);
		}
	}
}
Comment 1 Miguel de Icaza [MSFT] 2012-04-21 23:08:24 UTC
My bad, the above works if the [Setup] method has a "public".

But it still fails with the sysdrawing-coregraphics test suite, that has the proper signature for Setup.
Comment 3 Miguel de Icaza [MSFT] 2012-04-21 23:16:31 UTC
Operator error.