Bug 456 - Updater keeps trying to update MT 4.9 to 4.0.6
Summary: Updater keeps trying to update MT 4.9 to 4.0.6
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8 Alpha 2
Hardware: Macintosh Mac OS
: --- blocker
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-08-25 18:38 UTC by Larry Ewing [MSFT]
Modified: 2011-09-27 10:16 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Larry Ewing [MSFT] 2011-08-25 18:38:44 UTC
The automatic update logic keeps trying to replace MT 4.9 with MT 4.0.6 and the update dialog doesn't display the old/new version numbers to help you make a choice.
Comment 1 Chris Hardy [MSFT] 2011-08-29 14:43:15 UTC
Hey Larry,

Is this still an issue for you?

Could you recheck after we made some changes to this earlier today.

ChrisNTR
Comment 2 Larry Ewing [MSFT] 2011-08-29 18:21:57 UTC
What should I update to test?  Simply relaunching md from last week still shows the problem
Comment 3 Miguel de Icaza [MSFT] 2011-08-29 18:28:23 UTC
Are you using MonoDevelop 2.8 or another version?

We have only fixed the pre-2.8 updater.
Comment 4 Larry Ewing [MSFT] 2011-08-29 18:34:34 UTC
2.8 a 2 (2.7.11) is what is currently installed do I need to manually install something newer? or let it downgrade to mt 4.0.6 so that it can upgrade itself?
Comment 5 Miguel de Icaza [MSFT] 2011-09-27 10:16:55 UTC
This should be fixed now with the new pipeline and the udpates to the channels.