Bug 45559 - Buffer cannot be null.
Summary: Buffer cannot be null.
Status: RESOLVED DUPLICATE of bug 44569
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 6.1.0 (C8)
Hardware: Macintosh Mac OS
: --- critical
Target Milestone: (C9)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-17 13:07 UTC by Fokke Vermeulen
Modified: 2016-11-04 09:16 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 44569

Description Fokke Vermeulen 2016-10-17 13:07:31 UTC
# Steps to reproduce
I have a bigger project with a lot of xaml-files. From time to time, by trying to build the project it crashes and then it shows 103 errors and all "Buffer cannot be null"


# Expected behavior
The project should build correctly and deploy the version on the device

# Actual behavior
I get errors and have to restart and clean the project, to get it working again. Very frustating.

# Supplemental info (logs, images, videos)
We are using Xamarin.Forms.2.3.1.114

# Test environment (full version information)
Comment 1 Manish Sinha 2016-10-20 21:38:22 UTC
Hello Fokke,

Can you provide the build output, preferably diagnostic (Tools -> Options -> Build-> Log Verbosity)

Also can you post your About XS (Help -> About -> Show Details -> Copy Information)
Comment 2 Dan Ardelean 2016-11-04 06:31:05 UTC
Here is almost the same behaviour (sometime I get Buffer cannot be null with the latest XS on stable channel): https://1drv.ms/t/s!AuJWJQUKZPJoros9In9uVUYybLZylQ

The solution is to restart XS


Thank for looking into it!

Dan
Comment 3 Dan Ardelean 2016-11-04 06:51:33 UTC
Here is another one if needed: https://1drv.ms/t/s!AuJWJQUKZPJoros-PbjY18obocRP0Q
Comment 4 David Karlaš 2016-11-04 09:16:28 UTC
This is duplicate

*** This bug has been marked as a duplicate of bug 44569 ***