Bug 45487 - Xamarin.Forms ListView pull-to-refresh not working with iOS10 SDK
Summary: Xamarin.Forms ListView pull-to-refresh not working with iOS10 SDK
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-14 21:12 UTC by Alex Rainman
Modified: 2017-06-19 18:47 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Alex Rainman 2016-10-14 21:12:12 UTC
It works on Android but it doesn't do anything in iOS10 :(
Comment 1 Samantha Houts [MSFT] 2016-10-17 18:53:10 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue, we would very much appreciate it.  
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d  

Warm regards, 
Xamarin Forms Team
Comment 2 umutbebek 2016-10-24 09:44:53 UTC
Maybe you put listView in a scrollView. So it does not work :) I did that mistake and spent a lot of time to understand it. Just put your list view in a vertical or horizontal layout etc ;) 

xamarinforms:2.3.2.127 
ios 10.0.2

and set IsPullToRefreshEnabled=true of course on ListView
Comment 3 Samantha Houts [MSFT] 2017-06-19 18:47:46 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!