Bug 45272 - Problem wth target name in code analysis target
Summary: Problem wth target name in code analysis target
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 10.0 (iOS10)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-11 12:35 UTC by Mikhail Filippov
Modified: 2016-10-11 18:09 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikhail Filippov 2016-10-11 12:35:17 UTC
I found usage XIA0001.DisabledLinkerRule for target name in file /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Analysis.targets it is invalid target name. 
MsBuild has verification:
char[] illegalTargetNameCharacters = new char[] { '$', '@', '(', ')', '%', '*', '?', '.' };
If I try try build Xamarin project with MsBuild bundled with Mono I get error:
 "/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Analysis.targets(7,10): error MSB5016: The name "XIA0001.DisabledLinkerRule" contains an invalid character ".”.
Comment 1 Vincent Dondain [MSFT] 2016-10-11 14:35:20 UTC
This is now fixed in xamarin-macios:master (https://github.com/xamarin/xamarin-macios/commit/a4784b38665216072e7fc24fe218774ec288f52f)
Comment 2 Mikhail Filippov 2016-10-11 18:09:36 UTC
Great thanks!