Bug 45224 - after installing VS 15 preview 5, and using VS->tools->Xamarin settings to update to release channel, Xamarin VS does not work
Summary: after installing VS 15 preview 5, and using VS->tools->Xamarin settings to up...
Status: VERIFIED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: 4.2.1 (C8SR1)
Assignee: Bugzilla
URL:
: 46168 ()
Depends on:
Blocks:
 
Reported: 2016-10-10 08:47 UTC by philip
Modified: 2016-11-02 19:10 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description philip 2016-10-10 08:47:13 UTC
# Steps to reproduce
1. install VS 15 preview 5
2. go to VS->tools->Xamarin and update to release channel
3. re-open VS after update and VS->tools->Xamarin throws error and project does not build

# Expected behavior
Should be able to update to Xamarin release channel

# Actual behavior
update happens but Xamarin VS MEF no longer loads into VS

# Supplemental info (logs, images, videos)


# Test environment (full version information)
Comment 1 Ben Beckley 2016-10-11 15:17:07 UTC
Hello Philip,

Currently for Dev15 Xamarin bits can only be installed through the Dev15 installer. Also, the build on the release channel will not be compatible with Dev15.
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2016-11-02 19:10:27 UTC
*** Bug 46168 has been marked as a duplicate of this bug. ***