Bug 45219 - UWP Navigation-Bug after updating from Xamarin.Forms 2.3.1.114 to 2.3.2.127
Summary: UWP Navigation-Bug after updating from Xamarin.Forms 2.3.1.114 to 2.3.2.127
Status: RESOLVED DUPLICATE of bug 44886
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-10 07:45 UTC by Maik Süßenbach
Modified: 2016-10-14 18:52 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Environment (Word) and solution to reproduce the issue (360.14 KB, application/x-zip-compressed)
2016-10-10 07:45 UTC, Maik Süßenbach
Details
Solution from scratch to reproduce the bug (242.91 KB, application/x-zip-compressed)
2016-10-11 10:03 UTC, Maik Süßenbach
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 44886

Description Maik Süßenbach 2016-10-10 07:45:11 UTC
Created attachment 17951 [details]
Environment (Word) and solution to reproduce the issue

I'm developing a Xamarin.Forms PCL App for Android, iOS and UWP.
I use the normal NavigationPage to manage the navigation stack.

In Xamarin.Forms 2.3.1.114 everything runs well: Pressing the Back Button on a child page
will return to the previous page (on all platforms).

After updating from Xamarin.Forms 2.3.1.114 to 2.3.2.127 there seems to be a breaking change
for UWP Apps: Now i have to press the Back Button twice to return to the previous page. 
For Android and iOS everything runs well as in version 2.3.1.114.
This behaviour is not acceptable.

What changes have been made in UWP navigation ???

To reproduce the issue, i'm sending you a solution as an attachement. 
I have reduced the code and pages to the essentials.
Comment 1 Maik Süßenbach 2016-10-11 10:00:28 UTC
I have invested some time to analyse the issue. Now i'm able to reproduce the bug from scratch. The error occurs when navigating from a ListView-Item (via event "ItemSelected") to the next page. The same issue occurs after displaying an alert (via event "ItemSelected"). At latest from the second time, you have to press the Back-/OK-button twice to return to the previous page.

I have created a simple VS2015 solution to reproduce the issue (see second attachment). On Android and iOS everything works as expected.

What am I doing wrong???
Comment 2 Maik Süßenbach 2016-10-11 10:03:06 UTC
Created attachment 17979 [details]
Solution from scratch to reproduce the bug
Comment 3 Samantha Houts [MSFT] 2016-10-14 18:52:36 UTC

*** This bug has been marked as a duplicate of bug 44886 ***