Bug 45111 - If Android device qualifier/serial numer contain a space, deployement to device fail
Summary: If Android device qualifier/serial numer contain a space, deployement to devi...
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 7.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-10-06 12:59 UTC by Alex M
Modified: 2017-08-23 20:43 UTC (History)
7 users (show)

Tags: bb
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Alex M 2016-10-06 12:59:01 UTC
I have an Android tablet that will report its serial number/qualifier (using "adb devices") with a space (in  my case "ZTB X").

This causes the deploy to device to fail when getting the device API version using this command: 
1>C:\Users\<user>\AppData\Local\Android\android-sdk\platform-tools\adb.exe -s ZTB X  shell getprop ro.build.version.sdk 
1>"adb.exe" exited with code 1.
1>A numeric comparison was attempted on "$(_DeviceSdkVersion)" that evaluates to "" instead of a number, in condition "$(_DeviceSdkVersion) >= 21".
1>Build FAILED.

The failure is due to the '-s ZTB X' part. Since there is a space, the proper command should be adb.exe -s "ZTB X"  shell getprop ro.build.version.sdk
Comment 1 Alex M 2016-10-06 13:55:31 UTC
Just to add to my description, here is the output of the ADB command:

C:\Users\<user>>adb devices
List of devices attached
ZTB X   device
Comment 3 Dominic N [MSFT] 2017-07-03 19:07:30 UTC
Thank you for the report. Unfortunately, at this time, we're unable to reproduce this issue. I don't currently have access to any devices with a space in the qualifier. Alex - could you let us know what device you were using? I haven't been able to locate a device based on "ZTB X". I'll try to source something to test moving forward.

Setting to NEEDINFO for the time being.
Comment 4 Cody Beyer (MSFT) 2017-08-23 20:43:25 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!