Bug 4505 - Formatting a document with custom format does not work in the text editor
Summary: Formatting a document with custom format does not work in the text editor
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.9.x
Hardware: Macintosh Mac OS
: Normal major
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-04-18 14:58 UTC by lindsey.driscoll
Modified: 2012-04-18 15:30 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description lindsey.driscoll 2012-04-18 14:58:50 UTC
Description:

Screencast: http://screencast.com/t/mHcJP2S4UfH


With a custom c# source code format enabled, when trying to format a document (edit->format->format document) the text editor does not display correct format.

Then when attempting to format again without saving the text editor adds blank lines and when you click on the blank lines, it redisplays the old code.


Notes on formatting: (shown in the screen cast under // Notes comments

1. I have a custom format to place a space between the namespace declaration
   and the using statements at the header
2. I have a custom format to place 2 spaces between members in a given type


Environment:

MacOSX: Lion
MD: 2.9.5 (revision-a22f964653ff1e598ab0dfbf32a2e6679503fdbe)

This is seen on the latest master builds of MD for mac (2.9.5 series)

This is a regression from the latest stable version of MD (2.8.8.4)
This is not a regression from the latest alpha version of MD (2.9.4)
Comment 1 Mike Krüger 2012-04-18 15:17:03 UTC
fixed.
Comment 2 lindsey.driscoll 2012-04-18 15:30:20 UTC
Verified fix in 2.9.5 revision-f9c2d5b6db617474d33e2a48ec72367c0aed4630