Bug 45007 - Native linking failed, undefined symbol
Summary: Native linking failed, undefined symbol
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 10.0 (iOS10)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-04 12:03 UTC by Zdenek Musil
Modified: 2016-12-08 01:34 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Zdenek Musil 2016-10-04 12:03:26 UTC
Hi,
when I try to build project I got this errors.

Error		Native linking failed, undefined symbol: _DllBidTraceCW. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.	Client.iOS			
Error		Native linking failed, undefined symbol: _DllBidScopeEnterCW. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.	Client.iOS			
Error		Native linking failed. Please review the build log.	Client.iOS			
Error		Native linking failed, undefined symbol: _DllBidPutStrW. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.	Client.iOS			
Error		Native linking failed, undefined symbol: _DllBidCtlProc. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.	Client.iOS			
Error		Native linking failed, undefined symbol: _DllBidInitialize. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.	Client.iOS			
Error		Native linking failed, undefined symbol: _DllBidEntryPoint. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.	Client.iOS			
Error		Native linking failed, undefined symbol: _DllBidScopeLeave. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.	Client.iOS			
Error		Native linking failed, undefined symbol: _DllBidFinalize. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.	Client.iOS			


When my coleague try it the same solution on different mac and pc all is working. I tryed to reinstal xamarin to the new version on PC and MAC to. Without any change. I update mac OSx and visual studio. Nothing helps.
Comment 1 Timothy Risi 2016-10-04 17:07:13 UTC
Hi Zdenek,

Please include your full build logs, crash reports (if any), 
test case (to reproduce) and all version informations.

The easiest way to get exact version information is to use the 
"Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" 
button and copy/paste the version informations (you can use the 
"Copy Information" button).

It would also be helpful to have the environment information from the mac where everything worked.

Thanks
Comment 2 Timothy Risi 2016-12-08 01:34:00 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!