Bug 44894 - Could not AOT the assembly '.../obj/iPhone/Debug/mtouch-cache/64/Build/System.Net.Http.Formatting.dll'
Summary: Could not AOT the assembly '.../obj/iPhone/Debug/mtouch-cache/64/Build/System...
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler ()
Version: XI 10.0 (iOS10)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2016-09-29 16:52 UTC by Rafael Nicolett
Modified: 2016-12-08 01:35 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Could not AOT the assembly (6.60 MB, text/plain)
2016-09-29 16:52 UTC, Rafael Nicolett
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Rafael Nicolett 2016-09-29 16:52:46 UTC
Created attachment 17809 [details]
Could not AOT the assembly

When execute build in iOS 10 with Device iPhone, I have the error:

Could not AOT the assembly '.../obj/iPhone/Debug/mtouch-cache/64/Build/System.Net.Http.Formatting.dll'
Comment 1 Vincent Dondain [MSFT] 2016-09-29 17:21:19 UTC
Please include your full build logs, crash reports (if any), test case (to reproduce) and all version informations.

The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).
Comment 2 Rafael Nicolett 2016-09-29 17:26:20 UTC
My attachment this is include build logs, my version is 

=== Xamarin Studio Enterprise ===

Version 6.1.1 (build 15)
Installation UUID: b2c2aa7a-abd7-4a4b-ab32-88df5c2aefc8
Runtime:
	Microsoft .NET 4.0.30319.42000
	GTK+ 2.24.26 (Dark theme)
	GTK# 2.12.38

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Version: 0.34.2
Location: C:\Program Files (x86)\Xamarin\Profiler\XamarinProfiler.exe

=== Xamarin.Android ===

Version: 7.0.1.2 (Visual Studio Enterprise)
Android SDK: C:\Program Files (x86)\Android\android-sdk
	Supported Android versions:
		4.4 (API level 19)
		5.0 (API level 21)
		5.1 (API level 22)
		6.0 (API level 23)
		7.0 (API level 24)

SDK Tools Version: 25.2.2
SDK Platform Tools Version: 24.0.3
SDK Build Tools Version: 24.0.2

Java SDK: C:\Program Files\Java\jdk1.8.0_91
java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.91-b15, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 601010015
Git revision: fa52f02641726146e2589ed86ec4097fbe101888
Build date: 2016-09-22 08:12:03-04
Xamarin addins: 75d65712af93d54dc39ae4c42b21dfa574859fd6
Build lane: monodevelop-windows-cycle8-sr0

=== Operating System ===

Windows 10.0.14393.0 (64-bit)
Comment 3 Rafael Nicolett 2016-09-29 17:36:09 UTC
Update Version Information:

=== Xamarin Studio Enterprise ===

Version 6.1.1 (build 15)
Installation UUID: 11cf1e88-362e-4c17-b0ca-1bb83e81210d
Runtime:
	Mono 4.6.1 (mono-4.6.0-branch-c8sr0/abb06f1) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 406010003

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Version: 0.34.2
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 8.0 (11246)
Build 8A218a

=== Xamarin.Mac ===

Version: 2.10.0.103 (Visual Studio Enterprise)

=== Xamarin.iOS ===

Version: 10.0.1.8 (Visual Studio Enterprise)
Hash: 3983064
Branch: cycle8-sr0-xi
Build date: 2016-09-23 15:34:54-0400

=== Xamarin.Android ===

Version: 7.0.1.2 (Visual Studio Enterprise)
Android SDK: /Volumes/MacbookProHD/Android
	Supported Android versions:
		4.4 (API level 19)
		5.0 (API level 21)
		5.1 (API level 22)
		6.0 (API level 23)
		7.0 (API level 24)

SDK Tools Version: 25.2.2
SDK Platform Tools Version: 24.0.3
SDK Build Tools Version: 24.0.2

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 601010015
Git revision: fa52f02641726146e2589ed86ec4097fbe101888
Build date: 2016-09-22 08:03:02-04
Xamarin addins: 75d65712af93d54dc39ae4c42b21dfa574859fd6
Build lane: monodevelop-lion-cycle8-sr0

=== Operating System ===

Mac OS X 10.12.0
Darwin Rafaels-MacBook-Pro.local 16.0.0 Darwin Kernel Version 16.0.0
    Mon Aug 29 17:56:20 PDT 2016
    root:xnu-3789.1.32~3/RELEASE_X86_64 x86_64
Comment 4 Sebastien Pouliot 2016-09-30 18:53:01 UTC
/r:C:\git.tocalivros.projects\packages\Microsoft.AspNet.WebApi.Client.5.2.3\lib\portable-wp8+netcore45+net45+wp81+wpa81\System.Net.Http.Formatting.dll 

^ that assembly does not come from our SDK and it's path does not include Xamarin platforms (like normal PCL would do when supported), e.g.

/r:C:\git.tocalivros.projects\packages\SQLitePCL.raw_basic.0.8.6\lib\portable-net45+netcore45+wpa81+wp8+MonoAndroid10+MonoTouch10+Xamarin.iOS10\SQLitePCL.raw.dll
Comment 5 Rafael Nicolett 2016-09-30 19:12:07 UTC
I don't understand! I can build with Cycle 7 of Xamarin with iOS 9.3 but with Cycle 8 of Xamarin and iOS 10 I can't!
Comment 6 Sebastien Pouliot 2016-09-30 19:20:01 UTC
It's hard to say why. A lot of things are changing so both MS and Xamarin SDK moves toward unified netstandard profiles (c7 has minimal support, C8 has a lot of enhancements and so will C9) but it could be something else too.

Please attach the mentioned file to the bug report. This is not something we had (or produce) and having the exact binary might be important (as we could end up with a different one not showing the issue).

We'll try to see if we can reproduce the MT3001 using only that assembly.

Also if you have a C7-based build log please also attach it so we can compare them (in case it's a change/bug in the assembly resolution). Thanks!
Comment 7 Rafael Nicolett 2016-10-03 14:06:01 UTC
I will try to switch to .Net Standard
Comment 8 Rafael Nicolett 2016-10-03 15:19:01 UTC
I can not switch to .Net Standard has many compatibility issues.
Comment 9 Rafael Nicolett 2016-10-03 20:21:32 UTC
It's working now, I removed functionalities that use System.Net.Http.Formatting, and working now. Thank's
Comment 10 Sebastien Pouliot 2016-10-04 14:55:37 UTC
@Rafael, I'm glad to hear you could work around it. Still can you attach the assembly on the bug report ? just so we know why it failed and if we can fix this in any way. Thanks!
Comment 11 Timothy Risi 2016-12-08 01:35:44 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!