Bug 44807 - Forms code behind generator produces invalid code in *.Xamarin namespace
Summary: Forms code behind generator produces invalid code in *.Xamarin namespace
Status: RESOLVED DUPLICATE of bug 43301
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-28 04:20 UTC by Victor Milovanov
Modified: 2016-09-28 10:58 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 43301

Description Victor Milovanov 2016-09-28 04:20:41 UTC
Also possibly applies to .System namespace

Repro steps:
1. Create new Xaml Xamarin.Form project in Visual Studio, name it MyProject.Xamarin
2. Build MyProject.Xamarin

Expected:

Should build

Actual:
type or namespace name 'Forms' does not exist in the namespace 'MyProject.Xamarin'

Root cause:
generated code looks like this:
namespace MyProject.Xamarin {
  using System;
  using Xamarin.Forms; // <- this fails, as Xamarin refers to MyProjectXamarin
  ...
}

Must be: using global::Xamarin.Forms
Comment 1 Stephane Delcroix 2016-09-28 10:58:57 UTC

*** This bug has been marked as a duplicate of bug 43301 ***