Bug 44795 - mkbundle icall_wrapper_mono_generic_class_init
Summary: mkbundle icall_wrapper_mono_generic_class_init
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Tools ()
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-27 18:45 UTC by pr0vieh
Modified: 2016-10-18 22:01 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description pr0vieh 2016-09-27 18:45:04 UTC
when I try to bundle my tool

mkbundle -o mytool.exe --custom --deps --static --i18n all /somedir/mytool.exe /somedir/*.dll --config $defaultprefix/etc/mono/config --machine-config $defaultprefix/etc/mono/4.5/machine.config

all fine here...

but at startup i get a this Stacktrace:

.
.
.
Mono: Assembly Ref addref System.Configuration[0x2f8c5d0] -> System.Xml[0x2fb19e0]: 3
Mono: Assembly Ref addref System.Configuration[0x2f8c5d0] -> System[0x2e1f550]: 5
Mono: Assembly Loader probing location: '/usr/local/lib/mono/gac/I18N/4.0.0.0__0738eb9f132ed756/I18N.dll'.
Mono: Assembly Loader loaded assembly from bundle: 'I18N.dll'.
Mono: Image addref I18N[0x32ebe10] -> I18N.dll[0x305f8d0]: 3
Mono: Assembly I18N[0x32ebe10] added to domain mytool.exe, ref_count=1

Mono: Config attempting to parse: 'I18N.dll.config'.
Mono: Config attempting to parse: '/usr/local/etc/mono/assemblies/I18N/I18N.config'.
Mono: Assembly Ref addref I18N[0x3f11330] -> mscorlib[0x3c28310]: 8
Mono: Assembly Loader probing location: '/usr/local/lib/mono/gac/I18N.West/4.0.0.0__0738eb9f132ed756/I18N.West.dll'.
Mono: Assembly Loader loaded assembly from bundle: 'I18N.West.dll'.
Mono: Image addref I18N.West[0x3f9be40] -> I18N.West.dll[0x3f6b9d0]: 3
Mono: Assembly I18N.West[0x3f9be40] added to domain mytool.exe, ref_count=1

Mono: Config attempting to parse: 'I18N.West.dll.config'.
Mono: Config attempting to parse: '/usr/local/etc/mono/assemblies/I18N.West/I18N.West.config'.
Mono: Assembly Ref addref I18N.West[0x3f9be40] -> I18N[0x3f11330]: 2
Mono: Assembly Ref addref I18N.West[0x3f9be40] -> mscorlib[0x3c28310]: 9
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) string.FastAllocateString (int) <0x00053>
  at System.Globalization.TextInfo.ToLowerInternal (string) <0x00047>
  at System.Globalization.TextInfo.ToLower (string) <0x00023>
  at string.ToLower (System.Globalization.CultureInfo) <0x00032>
  at string.ToLower () <0x0001b>
  at mytool.HTMLheuristics..cctor () <0x000b3>
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0x0005a>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) object.__icall_wrapper_mono_generic_class_init (intptr) <0x00053>
  at mytool.HTMLparser..ctor () <0x00037>
  at mytool.Utils.Init () <0x0007b>
  at mytool.Utils..cctor () <0x00183>
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0x0005a>
  at <unknown> <0xffffffff>
  at mytool.mytoolTTY.Main (string[]) <0x00287>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0x000c8>

Native stacktrace:

        ./mytool.exe() [0x6bfbfd]
        ./mytool.exe() [0x65c19e]
        ./mytool.exe() [0x45aac3]
        /lib/x86_64-linux-gnu/libpthread.so.0(+0x113d0) [0x7f4e72a633d0]
        ./mytool.exe() [0x5c0087]
        ./mytool.exe() [0x5c10fb]
        ./mytool.exe() [0x5a1b74]
        ./mytool.exe() [0x5a2692]
        ./mytool.exe() [0x5a390a]
        ./mytool.exe() [0x59596a]
        ./mytool.exe() [0x54c23e]
        ./mytool.exe() [0x52aea2]
        ./mytool.exe() [0x56b6ba]
        [0x41cb9094]


is this related to PR #3069 ?

greets Pr0vieH
Comment 1 pr0vieh 2016-10-18 22:01:54 UTC
It seems fixed at testrun today

good work :)

thank you