Bug 44748 - Xamarin-Component.exe is creating invalid .xam files that cannot be opened by the store
Summary: Xamarin-Component.exe is creating invalid .xam files that cannot be opened by...
Status: RESOLVED FIXED
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: N/A
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
URL:
Depends on:
Blocks:
 
Reported: 2016-09-26 17:25 UTC by David Humphreys
Modified: 2016-11-01 21:54 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Humphreys 2016-09-26 17:25:19 UTC
Xamarin-Component.exe is creating invalid .xam files that cannot be opened by the store so they fail to upload correctly

Running the standard mac unzip tool produces and error

unzip video-player-1.2.0.xam -d test-video-player
Archive:  video-player-1.2.0.xam
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of video-player-1.2.0.xam or
        video-player-1.2.0.xam.zip, and cannot find video-player-1.2.0.xam.ZIP, period.
Comment 1 Bill Holmes 2016-09-26 19:33:00 UTC
I have our customer/submitter a request to try the latest version of xamarin-component.

https://www.nuget.org/api/v2/package/XamarinComponent/1.1.0.42

Not sure what we can do with this bug without more info to reproduce it.
Comment 2 David Humphreys 2016-11-01 21:54:22 UTC
This is due to not having the skip_docs setting set to true on a windows system that doesn't have mono installed.

Without skip_docs xamarin-component.exe will try an process the inline xml files and try call monodocs from the mono install.  as it can't find it, it crashes out but leaves the zip file open and undeleted.

Xamarin-component has been updated to fix the problem via pull request 53