Bug 44705 - iOS Simulator uses wrong version of command line tools when >1 version of xcode is installed
Summary: iOS Simulator uses wrong version of command line tools when >1 version of xco...
Status: RESOLVED FIXED
Alias: None
Product: Windows iOS Simulator
Classification: Xamarin
Component: Simulator ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 53943 ()
Depends on:
Blocks:
 
Reported: 2016-09-23 20:45 UTC by alan.grgic
Modified: 2017-04-03 14:33 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description alan.grgic 2016-09-23 20:45:00 UTC
For legacy application support reasons at my company, our Mac build host (OSX El Capitan) has multiple versions of xcode installed.
 
One is version 6.4 and located at /Applications/Xcode.app.
The other is version 7.3.1 and located at /Applications/xcode731/Xcode.app.

My Xamarin visual studio settings point the Xcode directory to use to /Applications/xcode731/Xcode.app.

When launching the app with the "remote to Windows" box unchecked, everything runs perfectly and appears on the simulator on the Mac as expected.

When the box is checked, I consistently get the "failed to install" error message. Unchecking the box and redeploying to the normal simulator, then checking the box again does not resolve this.

I found out by running "xcode-select-p" on the Mac that the command line tools version being used by default was at /Applications/Xcode.app/Contents/Developer (the 6.4 version).

I ran "xcode-select -switch /Applications/xcode731/Xcode.app/Contents/Developer" under an admin account to switch the default command line tools to be the 7.3.1 version. After doing this, the remote simulator to Windows works as expected (and when switching back to the 6.4 version once again does not work).

I would expect that the Xcode path indicated in the Visual Studio settings would dictate which version of the command line tools to use, i.e. the version of the command line tools that corresponds to the indicated xcode path should always be the version the remote simulator uses regardless of the machine's defaults.
Comment 1 Eric Maupin 2016-11-17 18:07:42 UTC
It should be using the Visual Studio settings path, and then if there's nothing set there it will fall back to xcode-select.

Can you attach your server logs from an instance of the VS settings not matching xcode-select? You'll find them at ~/Library/Logs/Xamarin/Simulator.Server
Comment 2 Eric Maupin 2017-03-24 18:05:59 UTC
*** Bug 53943 has been marked as a duplicate of this bug. ***
Comment 3 Eric Maupin 2017-03-24 18:06:40 UTC
Internal reproduction discovered, fixing.
Comment 4 alan.grgic 2017-03-25 20:19:54 UTC
I'm not sure how I missed your first reply, but sorry for not responding with the logs earlier. Glad you were able to reproduce and thanks in advance!
Comment 5 Eric Maupin 2017-03-30 21:33:31 UTC
This is fixed in 1.0.2
Comment 6 Eric Maupin 2017-04-03 14:33:42 UTC
*** Bug 54046 has been marked as a duplicate of this bug. ***