Bug 44690 - Item inside a ListView does not keep TranslationX after scroll
Summary: Item inside a ListView does not keep TranslationX after scroll
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-23 17:30 UTC by Leo
Modified: 2016-12-12 03:28 UTC (History)
3 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:


Attachments
project showing the bug (144.72 KB, application/x-zip-compressed)
2016-09-23 17:30 UTC, Leo
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 44690 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Leo 2016-09-23 17:30:04 UTC
Created attachment 17718 [details]
project showing the bug

On a ListView with CachingStrategy=RetainElement if I change the TranslationX of an ItemTemplate View to -50, after I scroll to hide the translated item and go back, it shows at 0 (but the translationx is still at -50). Here is an image showing the problem:

http://i.imgur.com/wco5iFZ.gif
Comment 1 adrianknight89 2016-10-21 17:58:36 UTC
I can confirm this issue in 2.3.3-pre3. Btw, you shouldn't set RowHeight to a value other than -1 if you want HasUnevenRows = true to work. Alternatively, you could avoid setting it.
Comment 2 adrianknight89 2016-12-12 01:31:35 UTC
This issue seems to happen if you set TranslationX on the ViewCell.View. If you set it in inner content, the value is retained.
Comment 3 adrianknight89 2016-12-12 03:28:50 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/637