Bug 44684 - [Profiler-Mac] Triangles are getting broken in Call Tree View.
Summary: [Profiler-Mac] Triangles are getting broken in Call Tree View.
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Mac ()
Version: 0.34.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: (C9)
Assignee: Jose Medrano
URL:
Depends on:
Blocks:
 
Reported: 2016-09-23 15:24 UTC by asimk
Modified: 2017-02-01 11:06 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: profiler-mac-0.34.0-36

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 2 Rodrigo Moya 2016-10-27 17:20:00 UTC
This is probably by the recent fixes from José Medrano on the drawing pipeline, so assigning to him so that he can verify and mark as fixed
Comment 3 xamarin-release-manager 2016-11-23 11:44:31 UTC
Fixed in version 1.1.99.29 (master)

Author: Jose?? Medrano
Commit: 1da533135cac57a32cf353bc83880cad8ebb42f5 (xamarin/profiler)
Comment 4 asimk 2016-11-23 17:39:40 UTC
I am still able to reproduce this issue with Profiler v1.1.99-40(Master).
Screencast: http://www.screencast.com/t/DAr7UchXUJ
Comment 8 Jose Medrano 2017-01-19 16:40:32 UTC
Asimk, can you test this issue with last master release? Thanks!
Comment 9 asimk 2017-01-20 13:05:18 UTC
@Jose, I am still getting this issue with latest master build i.e. 1.1.99.273
Here is the screencast for the same.
Screencast: https://www.screencast.com/t/XaQvTy2fj

Thanks!
Comment 10 xamarin-release-manager 2017-01-31 22:51:38 UTC
Fixed in version 1.1.99.317 (master)

Author: Jose?? Medrano
Commit: e4db1982106448244a76d914d9af99f255297b28 (xamarin/profiler)
Comment 11 Akhilesh kumar 2017-02-01 05:37:04 UTC
I have checked this issue with latest Master Profiler build i.e. 1.1.99.320 and I observed that now this issue is working fine.

Screencast: https://www.screencast.com/t/O8erYIbb1Eb

Please merge the fix in C9.

Thanks!!
Comment 12 Naqeeb 2017-02-01 11:06:52 UTC
I have checked this issue with latest C9 build i.e. profiler-mac-1.1.8-44_b6ae30298f1545049f9b4aa4c70779f5d831c346  and observed that it is working fine. Here is the screencast for the same: https://www.screencast.com/t/AkKoAyNNKx20

Hence closing this issue.

Thanks!