Bug 44665 - mtouch --listsim crashes with "Could not load the framework 'IDEFoundation'"
Summary: mtouch --listsim crashes with "Could not load the framework 'IDEFoundation'"
Status: RESOLVED INVALID
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: XI 10.0 (iOS10)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-23 00:03 UTC by Sandy Armstrong [MSFT]
Modified: 2016-09-23 13:35 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Sandy Armstrong [MSFT] 2016-09-23 00:03:40 UTC
$ /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mtouch -sdkroot /Applications/Xcode8.app --listsim=/Users/sandy/ls.txt
error HE0004: Could not load the framework 'IDEFoundation' (path: /Applications/Xcode8.app/Contents/Frameworks/IDEFoundation.framework/IDEFoundation): dlopen(/Applications/Xcode8.app/Contents/Frameworks/IDEFoundation.framework/IDEFoundation, 1): Library not loaded: @rpath/DVTAnalytics.framework/Versions/A/DVTAnalytics
  Referenced from: /Applications/Xcode8.app/Contents/Frameworks/IDEFoundation.framework/IDEFoundation
  Reason: image not found


If I call mlaunch directly, it works:

$ /Applications/Xamarin\ Studio.app/Contents/Resources/lib/monodevelop/AddIns/MonoDevelop.IPhone/mlaunch.app/Contents/MacOS/mlaunch -sdkroot /Applications/Xcode8.app --listsim=/Users/sandy/ls.txt
Simulator configuration written to /Users/sandy/ls.txt



=== Xamarin Studio Enterprise ===

Version 6.1 (build 5441)
Installation UUID: c8e0a9c3-4244-40de-9072-735d18850e7f
Runtime:
	Mono 4.6.0 (mono-4.6.0-branch/746756c) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 406000245

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 8.0 (11246)
Build 8A218a

=== Xamarin.iOS ===

Version: 9.8.0.58 (Xamarin Enterprise)
Hash: fa3b68c
Branch: master
Build date: 2016-03-09 11:44:54-0500

=== Xamarin.Android ===

Version: 6.1.0.16 (Xamarin Enterprise)
Android SDK: /Users/sandy/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.2   (API level 17)
		4.4   (API level 19)
		5.0   (API level 21)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 20.0.0

Java SDK: /usr
java version "1.8.0_20"
Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b23, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.99.2.35 (Xamarin Enterprise)

=== Xamarin Inspector ===

Version: 0.10.0.420
Hash: 22c0765
Branch: master
Build date: Wed, 21 Sep 2016 20:23:00 GMT

=== Build Information ===

Release ID: 601005441
Git revision: 68292d1ab289911c815ddc715dd7cc29a9752f9f
Build date: 2016-09-09 04:43:23-04
Xamarin addins: ed25d008672663eeb9db55f1ccecb3c24d2fd3b2
Build lane: monodevelop-lion-cycle8

=== Operating System ===

Mac OS X 10.11.6
Darwin Sandys-5k-iMac.local 15.6.0 Darwin Kernel Version 15.6.0
    Mon Aug 29 20:21:34 PDT 2016
    root:xnu-3248.60.11~1/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Addin Maker 1.3.2
Xamarin Inspector 0.10.0.420
Manifest.addin 0.0.0.0
Comment 3 Sandy Armstrong [MSFT] 2016-09-23 00:44:33 UTC
Unsurprisingly, mtouch -launchsim also produces the same crash (and mlaunch -launchsim is fine).
Comment 4 Rolf Bjarne Kvinge [MSFT] 2016-09-23 05:46:10 UTC
Do you have a /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mlaunch binary, or MLAUNCH_PATH set to something else?

I think this is because mtouch is somehow finding an old version of mlaunch, not the one shipped with XS.
Comment 5 Sandy Armstrong [MSFT] 2016-09-23 13:23:19 UTC
Nope, no other mlaunch that I can see. MLAUNCH_PATH is unset.
Comment 6 Sandy Armstrong [MSFT] 2016-09-23 13:33:23 UTC
I'm looking at this version info again and I think something went wrong with my upgrade on this system. That Xamarin.iOS is way too old.

Can't reproduce this bug on my main system.
Comment 7 Sandy Armstrong [MSFT] 2016-09-23 13:35:39 UTC
Sorry for the noise. Confirmed that my upgrade went bad somehow, and after actually upgrading Xamarin.iOS, all is fine.