Bug 44632 - Random/intermittent Mac Agent disconnects during msbuild command line
Summary: Random/intermittent Mac Agent disconnects during msbuild command line
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: 4.4.0 (C10)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-22 17:24 UTC by Randy
Modified: 2017-01-09 18:14 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
zip of xamarin logs (47.25 KB, application/x-zip-compressed)
2016-09-22 17:24 UTC, Randy
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Randy 2016-09-22 17:24:07 UTC
Created attachment 17687 [details]
zip of xamarin logs

msbuild solution from command line, randomly get the Mac Agent disconnected error.  Frequency has seemed to decrease once I changed /m to /m:4.  Could be a coincidence.

Solution contains three iOS projects, some of the iOS projects will build fine, others not because of disconnect.

MSBUILD log snippet:
****************************************************************************************************************
04:50:05          Using shared compilation with compiler from directory: C:\Program Files (x86)\MSBuild\14.0\bin
04:50:06     20>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : Only one usage of each socket address (protocol/network address/port) is normally permitted [C:\Jenkins\jobs\PROJECT\workspace\PROJECT\trunk\Xamarin\PROJECT\Apps\PROJECT.iOS\PROJECT.iOS.csproj]
04:50:06 
    20>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning VSX1000: The project PROJECT.iOS was built while disconnected from a Mac agent, so only the main assembly was compiled. Connect to a Xamarin Mac build agent to build the full application. [C:\Jenkins\jobs\PROJECT\workspace\PROJECT\trunk\Xamarin\PROJECT\Apps\PROJECT.iOS\PROJECT.iOS.csproj]

04:54:00 
    20>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.After.targets(208,5): error : There was an error unzipping the file bin\iPhone\Release\PROJECTiOS.app.dSYM.zip: Could not find file 'C:\Jenkins\jobs\PROJECT\workspace\PROJECT\trunk\Xamarin\PROJECT\Apps\PROJECT.iOS\bin\iPhone\Release\PROJECTiOS.app.dSYM.zip'. [C:\Jenkins\jobs\PROJECT\workspace\PROJECT\trunk\Xamarin\PROJECT\Apps\PROJECT.iOS\PROJECT.iOS.csproj]

04:58:50          C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.After.targets(208,5): error : There was an error unzipping the file bin\iPhone\Release\PROJECTiOS.app.dSYM.zip: Could not find file 'C:\Jenkins\jobs\PROJECT\workspace\PROJECT\trunk\Xamarin\PROJECT\Apps\PROJECT.iOS\bin\iPhone\Release\PROJECTiOS.app.dSYM.zip'. [C:\Jenkins\jobs\PROJECT\workspace\PROJECT\trunk\Xamarin\PROJECT\Apps\PROJECT.iOS\PROJECT.iOS.csproj]

****************************************************************************************************************


Most of the time, after getting the above error, I can do a rebuild with no changes and the solution builds fine.

Attaching Xamarin logs but not sure they will help as they look to be IDE logs?
Comment 1 mag@xamarin.com 2016-12-22 20:23:22 UTC
Moving to cycle10 for further investigation
Comment 2 mag@xamarin.com 2017-01-09 18:14:17 UTC
Many changes around iOS build process, specially related to Mac Connection handling, has been made. These changes will be available from Xamarin cycle10 release.

Marking the bug as Resolved and assigning to QA for testing for cycle10. This should be tested on master branch from commit 24c2eb75f5956179d09c7a3fb9baf9579bd8255e