Bug 44619 - Loading WebView on Android Device 5.1 Crashes - Could not load type WebViewRenderer+WebClient
Summary: Loading WebView on Android Device 5.1 Crashes - Could not load type WebViewRe...
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-22 12:26 UTC by Andrew Herrick
Modified: 2016-10-04 12:50 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
error message (32.95 KB, image/png)
2016-09-22 12:26 UTC, Andrew Herrick
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Andrew Herrick 2016-09-22 12:26:15 UTC
Created attachment 17673 [details]
error message

In a simple Forms solution receiving the following error when trying to load a WebView on Android device:

could not load type 'Xamarin.Forms.Platform.Android.WebViewRenderer+WebClient' from assembly 'Xamarin.Forms.Platform.Android, Version=2.0.0.0

I made a File => New sample to isolate:

https://dl.dropboxusercontent.com/u/4298416/Forms/FormsDroidWebView.zip

Additional Information:

Compiled against Android 5.1
UWP + iOS do work fine
Comment 1 Stephane Delcroix 2016-10-04 12:50:35 UTC
I was able to reproduce the issue with the attached project.

removing the bin and obj folders in the android project, cleaning and rebuilding fixed it.

it should fix that for you as well