Bug 44558 - UILabel.Layer.BorderWidth was not showing properly when running the application in iOS Simulator for iPad 2 in iOS 9.3
Summary: UILabel.Layer.BorderWidth was not showing properly when running the applicati...
Status: RESOLVED UPSTREAM
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 9.6 (iOS 9.3)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-21 09:10 UTC by Ganesan VG
Modified: 2016-11-02 10:25 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
We have attched the sample by setting Layer.BorderWidth to UILabel. Border was not showing properly when we run in IPad 2 (711.85 KB, application/x-zip-compressed)
2016-09-21 09:10 UTC, Ganesan VG
Details
iPad 2 iOS 9.3 screenshot (8.65 KB, image/png)
2016-09-27 05:16 UTC, Ashok
Details
iPad Air 2 iOS 9.3 screenshot (6.75 KB, image/png)
2016-09-27 05:17 UTC, Ashok
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Ganesan VG 2016-09-21 09:10:53 UTC
Created attachment 17635 [details]
We have attched the sample by setting Layer.BorderWidth to UILabel. Border was not showing properly when we run in IPad 2

Layer.BorderWidth was not showing when running the sample in iOS Simulator for iPad 2 in iOS 9.3. And we can able to see the borders when I run the application on the iOS Simulator for iPad Air 2.
Comment 1 Alex Soto [MSFT] 2016-09-22 15:13:37 UTC
Hello Ganesan

Could you please elaborate on "not showing properly"? Maybe by adding a screenshot. I am running this project and I do see the green border on iPad Air 2 simulator on 9.3 and also on physical devices.

Also please include your version information, the easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the 
"Copy Information" button).

Cheers!
Comment 2 Ashok 2016-09-27 05:15:44 UTC
Hi Cheers,

Sorry for the delay. 

If I run the sample in iPad Air 2 iOS 9.3, I will get the border vertically but if I run iPad 2 iOS 9.3 , I didn't get the vertical border. I have attached the screenshot for this issue, please check.

Regards,
Ashok
Comment 3 Ashok 2016-09-27 05:16:50 UTC
Created attachment 17756 [details]
iPad 2 iOS 9.3 screenshot
Comment 4 Ashok 2016-09-27 05:17:43 UTC
Created attachment 17757 [details]
iPad Air 2 iOS 9.3 screenshot
Comment 5 Vincent Dondain [MSFT] 2016-10-27 14:01:51 UTC
Hi,

Thanks for the precisions. It seems to be working fine on both the iPad 2 and iPad Air 2 simulators for me.

iPad Air 2 iOS 9.3: https://www.dropbox.com/s/mzo665m6hziig0o/Screenshot%202016-10-27%2015.51.43.png?dl=0

iPad 2 iOS 9.3: https://www.dropbox.com/s/165jgkifjmdy7lc/Screenshot%202016-10-27%2015.52.19.png?dl=0

Also as Alex said please include your version information.

I'm using: https://gist.github.com/VincentDondain/b3d93dae7e60b4741db4285e103bfc51

I consider this bug likely resolved upstream, please give it a try with our current stable release and feel free to re-open if you're still experiencing the same issue.