Bug 44505 - Getting Sharing Violation When Attempting to Link on SD Drive
Summary: Getting Sharing Violation When Attempting to Link on SD Drive
Status: RESOLVED DUPLICATE of bug 38538
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-19 21:12 UTC by richard
Modified: 2016-09-22 15:44 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 38538

Description richard 2016-09-19 21:12:43 UTC
Description of Problem:


Steps to reproduce the problem:
1. Go to Link ( works normally off main hard drive ) by compiling off source tree on SD Drive



Actual Results:

Get this error.

/Volumes/MicroSD/richard_dev2/trunkRel/Products/iCropTrakApp/MTOUCH: Error MT2001: Could not link assemblies. Reason: Sharing violation on path /Volumes/MicroSD/richard_dev2/trunkRel/Products/iCropTrakApp/obj/iPhone/Release/mtouch-cache/64/PreBuild/System.Runtime.Serialization.dll.mdb (MT2001) (iCropTrakApp)


Expected Results:

Not to get a sharing violation and have the link complete.


How often does this happen? 

Everytime I try to compile and build off the SD Drive.


Additional Information:
Comment 1 Alex Soto [MSFT] 2016-09-22 15:32:05 UTC
Hello Richard

By any chance, is your MicroSD partition formatted in FAT32?
Comment 2 richard 2016-09-22 15:35:20 UTC
It says ExFAT. On the other other hand it also says it was created in 1969 - I didn't know this technology existed then !
Comment 3 Rolf Bjarne Kvinge [MSFT] 2016-09-22 15:44:33 UTC
Yeah, this is a known problem.

Maybe try formatting using some different file system.

*** This bug has been marked as a duplicate of bug 38538 ***