Bug 44490 - mtouch --killdev failing
Summary: mtouch --killdev failing
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 10.0 (iOS10)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-19 13:16 UTC by Antonio
Modified: 2016-09-20 08:23 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Antonio 2016-09-19 13:16:05 UTC
Hello,

I've always been using this line in my makefile with no issues:

/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mtouch --killdev com.novarumdx.imaging.ios.test

Since i updated Xamarin Environment to latest in stable (community) i started having:

warning MT0061: No Xcode.app specified (using --sdkroot), using the system Xcode as reported by 'xcode-select --print-path': /Applications/Xcode.app/Contents/Developer
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
System.IO.FileNotFoundException: Could not find required file 'com.novarumdx.imaging.ios.test/Info.plist'.
  at Xamarin.Hosting.PList.FromFile (System.String name) <0x10fb0f890 + 0x000f1> in <filename unknown>:0 
  at Xamarin.Hosting.AppBundle..ctor (System.String path) <0x10fb0f7b0 + 0x0006d> in <filename unknown>:0 
  at Xamarin.Launcher.Driver.Main2 (System.String[] args) <0x10f947010 + 0x02489> in <filename unknown>:0 
  at Xamarin.Launcher.Driver.Main (System.String[] args) <0x10b1e8c00 + 0x0009a> in <filename unknown>:0 
[MVID] 703d5be3b466420882f6cb97c41b6723 0,1
[MVID] 9a558991a2c447e1a28d274b8a5171e7 2,3

(NOTE: i can deploy the same test project app through xamarin studio with no issues)

Could you please advise?
Comment 1 Rolf Bjarne Kvinge [MSFT] 2016-09-19 15:38:59 UTC
Try pasing the path of the built .app on your disk instead of the bundle id.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2016-09-19 15:39:10 UTC
*Try passing
Comment 3 Antonio 2016-09-19 15:43:24 UTC
Thanks Rolf,

The error is "better" but still undesirable (error MT1005) - "Could not kill the application. You may have to kill the application manually. You may have to kill the application manually"
Comment 4 Rolf Bjarne Kvinge [MSFT] 2016-09-19 15:45:07 UTC
Can you attach the full output of executing the following


    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mtouch -vvvv --killdev /path/to/app.app
Comment 5 Antonio 2016-09-19 15:47:24 UTC
Thanks Rolf,

Running : "/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mtouch -vvvv --killdev NovarumDX.Imaging.iOS.Test/bin/iPhone/Release/NovarumDX.Imaging.iOS.Test.app"

shows the following:

xcode-select -p
/Applications/Xcode.app/Contents/Developer

warning MT0061: No Xcode.app specified (using --sdkroot), using the system Xcode as reported by 'xcode-select --print-path': /Applications/Xcode.app/Contents/Developer
Using Xcode 8.0 found in /Applications/Xcode.app/Contents/Developer
Forwarding to mlaunch
Using Xcode 8.0 found in /Applications/Xcode.app/Contents/Developer
Killing the application 'NovarumDX.Imaging.iOS.Test/bin/iPhone/Release/NovarumDX.Imaging.iOS.Test.app' on the device ''
Please ensure your device is connected...
Connected to: iPhone
error MT1005: Could not kill the application 'NovarumDX.Imaging.iOS.Test/bin/iPhone/Release/NovarumDX.Imaging.iOS.Test.app' on the device: Could not kill the application 'NovarumDX.Imaging.iOS.Test/bin/iPhone/Release/NovarumDX.Imaging.iOS.Test.app'. You may have to kill the application manually.. You may have to kill the application manually.
Comment 6 Rolf Bjarne Kvinge [MSFT] 2016-09-19 18:05:19 UTC
Actually there is a bug here, it doesn't work.

Fixed: maciostools/master: 1f80382763996af1461153d4b55aff54a7f5060b

Unfortunately I can't come up with any workarounds for the moment (except that installing an app will make iOS kill the app if it's running, so you might be able to do that instead).
Comment 7 Antonio 2016-09-20 08:23:56 UTC
Thanks Rolf,

I'll amend the Makefile to just use install and not kill.