Bug 44439 - Xamarin.Android app crashing
Summary: Xamarin.Android app crashing
Status: RESOLVED DUPLICATE of bug 44633
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2016-09-16 20:14 UTC by Alex Rainman
Modified: 2016-11-04 18:52 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 44633

Description Alex Rainman 2016-09-16 20:14:44 UTC
Cannot run any Android project. The app crash when deployed.

[art] Not late-enabling -Xcheck:jni (already on)
[AndroidRuntime] Shutting down VM
[AndroidRuntime] FATAL EXCEPTION: main
[AndroidRuntime] Process: com.slbdev.LoadChart.Droid, PID: 4726
[AndroidRuntime] java.lang.RuntimeException: Unable to instantiate application md527a7919e283623d91a69ee9a78351a60.MainApplication: java.lang.ClassNotFoundException: Didn't find class "md527a7919e283623d91a69ee9a78351a60.MainApplication" on path: DexPathList[[zip file "/data/app/com.slbdev.LoadChart.Droid-1/base.apk"],nativeLibraryDirectories=[/data/app/com.slbdev.LoadChart.Droid-1/lib/x86, /data/app/com.slbdev.LoadChart.Droid-1/base.apk!/lib/x86, /vendor/lib, /system/lib]]
[AndroidRuntime] 	at android.app.LoadedApk.makeApplication(LoadedApk.java:578)
[AndroidRuntime] 	at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4680)
[AndroidRuntime] 	at android.app.ActivityThread.-wrap1(ActivityThread.java)
[AndroidRuntime] 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1405)
[AndroidRuntime] 	at android.os.Handler.dispatchMessage(Handler.java:102)
[AndroidRuntime] 	at android.os.Looper.loop(Looper.java:148)
[AndroidRuntime] 	at android.app.ActivityThread.main(ActivityThread.java:5417)
[AndroidRuntime] 	at java.lang.reflect.Method.invoke(Native Method)
[AndroidRuntime] 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:726)
[AndroidRuntime] 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)
[AndroidRuntime] Caused by: java.lang.ClassNotFoundException: Didn't find class "md527a7919e283623d91a69ee9a78351a60.MainApplication" on path: DexPathList[[zip file "/data/app/com.slbdev.LoadChart.Droid-1/base.apk"],nativeLibraryDirectories=[/data/app/com.slbdev.LoadChart.Droid-1/lib/x86, /data/app/com.slbdev.LoadChart.Droid-1/base.apk!/lib/x86, /vendor/lib, /system/lib]]
[AndroidRuntime] 	at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:56)
[AndroidRuntime] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:511)
[AndroidRuntime] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:469)
[AndroidRuntime] 	at android.app.Instrumentation.newApplication(Instrumentation.java:981)
[AndroidRuntime] 	at android.app.LoadedApk.makeApplication(LoadedApk.java:573)
[AndroidRuntime] 	... 9 more
[AndroidRuntime] 	Suppressed: java.io.IOException: No original dex files found for dex location /data/app/com.slbdev.LoadChart.Droid-1/base.apk
[AndroidRuntime] 		at dalvik.system.DexFile.openDexFileNative(Native Method)
[AndroidRuntime] 		at dalvik.system.DexFile.openDexFile(DexFile.java:295)
[AndroidRuntime] 		at dalvik.system.DexFile.<init>(DexFile.java:80)
[AndroidRuntime] 		at dalvik.system.DexFile.<init>(DexFile.java:59)
[AndroidRuntime] 		at dalvik.system.DexPathList.loadDexFile(DexPathList.java:279)
[AndroidRuntime] 		at dalvik.system.DexPathList.makePathElements(DexPathList.java:248)
[AndroidRuntime] 		at dalvik.system.DexPathList.<init>(DexPathList.java:120)
[AndroidRuntime] 		at dalvik.system.BaseDexClassLoader.<init>(BaseDexClassLoader.java:48)
[AndroidRuntime] 		at dalvik.system.PathClassLoader.<init>(PathClassLoader.java:65)
[AndroidRuntime] 		at android.app.ApplicationLoaders.getClassLoader(ApplicationLoaders.java:58)
[AndroidRuntime] 		at android.app.LoadedApk.getClassLoader(LoadedApk.java:376)
[AndroidRuntime] 		at android.app.LoadedApk.makeApplication(LoadedApk.java:568)
[AndroidRuntime] 		... 9 more
[AndroidRuntime] 	Suppressed: java.lang.ClassNotFoundException: md527a7919e283623d91a69ee9a78351a60.MainApplication
[AndroidRuntime] 		at java.lang.Class.classForName(Native Method)
[AndroidRuntime] 		at java.lang.BootClassLoader.findClass(ClassLoader.java:781)
[AndroidRuntime] 		at java.lang.BootClassLoader.loadClass(ClassLoader.java:841)
[AndroidRuntime] 		at java.lang.ClassLoader.loadClass(ClassLoader.java:504)
[AndroidRuntime] 		... 12 more
[AndroidRuntime] 	Caused by: java.lang.NoClassDefFoundError: Class not found using the boot class loader; no stack trace available
[Process] Sending signal. PID: 4726 SIG: 9
Comment 1 Alex Rainman 2016-09-19 13:40:45 UTC
I was able to fix this. I downgraded my Xamarin.Android to version 6.1.2. It seems the problem is latest Xamarin.Android version.
Comment 2 Mohammad Zekrallah 2016-09-26 08:47:41 UTC
I confirm the same bug .. it started appearing right after updating to Xamarin 6.0 and 6.1.1 doesn't solve it either .. it happens in debug mode only .. I have DEX and fast deployment enabled. 

=== Xamarin Studio Business ===

Version 6.1.1 (build 15)
Installation UUID: 5afdb4e6-1d91-47f2-8fc2-59000d17061a
Runtime:
	Mono 4.6.0 (mono-4.6.0-branch/8d0eee7) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 406000251

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 7.0.1.1 (Xamarin Business)
Android SDK: /Volumes/Data/Android/SDK
	Supported Android versions:
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)
		7.0    (API level 24)

SDK Tools Version: 25.2.2
SDK Platform Tools Version: 24.0.3
SDK Build Tools Version: 24.0.2

Java SDK: /usr
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 8.0 (11246)
Build 8A218a

=== Xamarin.Mac ===

Not Installed

=== Xamarin.iOS ===

Version: 10.0.1.5 (Xamarin Business)
Hash: c9eb5b0
Branch: xcode8
Build date: 2016-09-16 20:50:23-0400

=== Build Information ===

Release ID: 601010015
Git revision: fa52f02641726146e2589ed86ec4097fbe101888
Build date: 2016-09-22 08:03:02-04
Xamarin addins: 75d65712af93d54dc39ae4c42b21dfa574859fd6
Build lane: monodevelop-lion-cycle8-sr0

=== Operating System ===

Mac OS X 10.11.6
Darwin Mohammads-MacBook-Pro.local 15.6.0 Darwin Kernel Version 15.6.0
    Mon Aug 29 20:21:34 PDT 2016
    root:xnu-3248.60.11~1/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Redth's Addins 1.0.2
Comment 3 jellis 2016-10-28 13:33:14 UTC
confirmed seeing the same bug running Xamarin Studio on Macbook with latest stable Xamarin Android - on Debug build with Shared runtime enabled.  Turning off shared runtime resolves for now.  I believe it is the same bug as this one: https://bugzilla.xamarin.com/show_bug.cgi?id=44439
Comment 4 Jonathan Pryor 2016-11-04 18:47:25 UTC
This looks like a DUPE of Bug #44633:

> No original dex files found for dex location /data/app/com.slbdev.LoadChart.Droid-1/base.apk

*** This bug has been marked as a duplicate of bug 44633 ***
Comment 5 jellis 2016-11-04 18:52:17 UTC
This one may also be a dupe:
https://bugzilla.xamarin.com/show_bug.cgi?id=45280