Bug 4442 - Method evaluating takes too long and then it ends with Unknown identifier
Summary: Method evaluating takes too long and then it ends with Unknown identifier
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 2.8.8.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-04-15 13:49 UTC by pinggi
Modified: 2012-04-16 12:16 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Unknown identifier (7.66 KB, image/png)
2012-04-15 13:49 UTC, pinggi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description pinggi 2012-04-15 13:49:14 UTC
Created attachment 1670 [details]
Unknown identifier

Here is a sample code:

public class Rendering
{
	public void Start()
	{
		thread = new Thread(new ThreadStart(RenderingLoop)); // breakpoint
		thread.Start();
	}
		
	private void RenderingLoop()
	{
	}
}

If I put breakpoint on the line starting with "thread = ...", run it in debug mode and move mouse over the RenderingLoop variable, Monodevelop is not able to evaluate this variable. If I move mouse out of it and return back it shows me "Unknown identifier: RenderingLoop".
Comment 1 Jeffrey Stedfast 2012-04-16 12:16:03 UTC
fixed in git master